summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-08-02 17:49:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-08-02 17:49:57 +0200
commit01763e53175661b80fd777485b162d6c54a813fd (patch)
tree7be10fa3feeada87701b24f5c1af99ca2478265a /sys-apps/keyutils
parentapp-portage/gentoolkit: Enable py3.7 (diff)
downloadgentoo-01763e53175661b80fd777485b162d6c54a813fd.tar.gz
gentoo-01763e53175661b80fd777485b162d6c54a813fd.tar.bz2
gentoo-01763e53175661b80fd777485b162d6c54a813fd.zip
sys-apps/keyutils: Removed old.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'sys-apps/keyutils')
-rw-r--r--sys-apps/keyutils/keyutils-1.5.9-r1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/sys-apps/keyutils/keyutils-1.5.9-r1.ebuild b/sys-apps/keyutils/keyutils-1.5.9-r1.ebuild
deleted file mode 100644
index 5dd6f75e4ce1..000000000000
--- a/sys-apps/keyutils/keyutils-1.5.9-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit multilib eutils toolchain-funcs linux-info multilib-minimal
-
-DESCRIPTION="Linux Key Management Utilities"
-HOMEPAGE="https://people.redhat.com/dhowells/keyutils/"
-SRC_URI="https://people.redhat.com/dhowells/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="!prefix? ( >=sys-kernel/linux-headers-2.6.11 )"
-
-pkg_setup() {
- CONFIG_CHECK="~KEYS"
- use test && CONFIG_CHECK="${CONFIG_CHECK} ~KEYS_DEBUG_PROC_KEYS"
- ERROR_KEYS="You must have CONFIG_KEYS to use this package!"
- ERROR_KEYS_DEBUG_PROC_KEYS="You must have CONFIG_KEYS_DEBUG_PROC_KEYS to run the package testsuite!"
- linux-info_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.5.5-makefile-fixup.patch
-
- # The lsb check is useless, so avoid spurious command not found messages.
- sed -i -e 's,lsb_release,:,' tests/prepare.inc.sh || die
- # All the test files are bash, but try to execute via `sh`.
- sed -i -r \
- -e 's:([[:space:]])sh([[:space:]]):\1bash\2:' \
- tests/{Makefile*,*.sh} || die
- find tests/ -name '*.sh' -exec sed -i '1s:/sh$:/bash:' {} +
- # Some tests call the kernel which calls userspace, but that will
- # run the install keyutils rather than the locally compiled one,
- # so disable round trip tests.
- rm -rf tests/keyctl/requesting/{bad-args,piped,valid}
-
- multilib_copy_sources
-}
-
-multilib_src_compile() {
- tc-export CC
- tc-export AR
- sed -i \
- -e '1iRPATH=' \
- -e '/^C.*FLAGS/s|:=|+=|' \
- -e 's:-Werror::' \
- -e '/^BUILDFOR/s:=.*:=:' \
- -e "/^LIBDIR/s:=.*:= /usr/$(get_libdir):" \
- -e '/^USRLIBDIR/s:=.*:=$(LIBDIR):' \
- -e "s: /: ${EPREFIX}/:g" \
- Makefile || die
-
- emake
-}
-
-multilib_src_test() {
- # Execute the locally compiled code rather than the
- # older versions already installed in the system.
- LD_LIBRARY_PATH=${BUILD_DIR} \
- PATH="${BUILD_DIR}:${PATH}" \
- emake test
-}
-
-multilib_src_install() {
- default
- gen_usr_ldscript -a keyutils
-}
-
-multilib_src_install_all() {
- dodoc README
-}