summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/nca
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/nca')
-rw-r--r--sys-apps/nca/Manifest1
-rw-r--r--sys-apps/nca/files/ncad.initd16
-rw-r--r--sys-apps/nca/metadata.xml16
-rw-r--r--sys-apps/nca/nca-0.9.0.ebuild42
4 files changed, 75 insertions, 0 deletions
diff --git a/sys-apps/nca/Manifest b/sys-apps/nca/Manifest
new file mode 100644
index 000000000000..b3a2b81ff177
--- /dev/null
+++ b/sys-apps/nca/Manifest
@@ -0,0 +1 @@
+DIST nca-0.9.0.tar.gz 818721 SHA256 407144394f6f90e818c7ce992a691c4e99983defbe9de63f6a0adaa93a36ae03 SHA512 375dc747414af7e8971a9112fa6a4583dd543f6f4b3a84b2c16f45ee2487363929c2eed3c1837687b802161c630443885e6da20ac738017d219e9a608b4d700c WHIRLPOOL 60c726e918e3684fe9dc45eacbfb2aa264f7ea1fd71e46eacc2020252e5cf6b333345c000eb8efafba65965fe184ff1ad4cbc87886a623831476f18c052953d9
diff --git a/sys-apps/nca/files/ncad.initd b/sys-apps/nca/files/ncad.initd
new file mode 100644
index 000000000000..5e7fff2fed87
--- /dev/null
+++ b/sys-apps/nca/files/ncad.initd
@@ -0,0 +1,16 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --quiet --exec /sbin/ncad
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --retry 5 --quiet --exec /sbin/ncad
+ eend ${?}
+}
diff --git a/sys-apps/nca/metadata.xml b/sys-apps/nca/metadata.xml
new file mode 100644
index 000000000000..b09d87bd4291
--- /dev/null
+++ b/sys-apps/nca/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ nca connects a pseudo terminal to the console's virtual terminals
+ (/dev/tty0...n) that are normally only accessible to someone with
+ local keyboard access. It is particularly useful in conjunction with
+ ncad since it then provides remote console access via SSH; with some
+ appropriate system start up scripts, ncad can be started immediately
+ the root filesystem has been mounted read-only, providing a cheap,
+ and only marginally inferior alternative to a serial console.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/nca/nca-0.9.0.ebuild b/sys-apps/nca/nca-0.9.0.ebuild
new file mode 100644
index 000000000000..0c7bc45b2a05
--- /dev/null
+++ b/sys-apps/nca/nca-0.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Network Console on Acid"
+HOMEPAGE="http://www.xenoclast.org/nca/"
+SRC_URI="http://www.xenoclast.org/nca/download/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl
+ sys-libs/zlib"
+
+DEPEND="dev-lang/perl
+ ${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s:^\([[:space:]]\+\$(MAKE) install\):\1 DESTDIR=\$(DESTDIR):g" \
+ -e "s:=\(\$(CFLAGS)\):=\"\1\":g" -e "s:=\(\$(CC)\):=\"\1\":g" Makefile
+
+ sed -i -e "s:-s sshd:sshd:g" ncad.patch
+}
+
+src_compile() {
+ emake -j1 CFLAGS="${CFLAGS}" CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ dodir /sbin
+ emake BINDIR="${D}sbin" MANDIR="${D}usr/share/man" SYSCONF_DIR="${D}etc" \
+ DESTDIR="${D}" install_nca install_ssh install_man
+
+ newinitd "${FILESDIR}/ncad.initd" ncad
+ dodoc ChangeLog README* rc/ncad.template
+}