summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-19 02:55:09 +0100
committerSam James <sam@gentoo.org>2022-06-19 02:55:27 +0100
commit47b281903a5daa245c84532e1c83ec7b2865085d (patch)
treede501432f21731d7a47580ff8601ba63595008d0 /sys-apps/pcsc-tools
parentdev-dotnet/dotnet-sdk-bin: drop old 6.0.202-r1 (diff)
downloadgentoo-47b281903a5daa245c84532e1c83ec7b2865085d.tar.gz
gentoo-47b281903a5daa245c84532e1c83ec7b2865085d.tar.bz2
gentoo-47b281903a5daa245c84532e1c83ec7b2865085d.zip
sys-apps/pcsc-tools: fix gtk dependency
Closes: https://bugs.gentoo.org/793815 Bug: https://bugs.gentoo.org/821997 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/pcsc-tools')
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.5.7-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.5.7-r1.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.5.7-r1.ebuild
new file mode 100644
index 000000000000..929e971d6b8b
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.5.7-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="gtk network-cron"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="${DEPEND}
+ dev-perl/pcsc-perl
+ gtk? ( dev-perl/Gtk3 )"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(
+ README Changelog
+)
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gtk; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gtk && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}