summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2017-07-03 05:29:06 -0400
committerJoshua Kinard <kumba@gentoo.org>2017-07-03 05:29:52 -0400
commitcc0a6ca146a0bec4827da69f5ddb60e12c02f181 (patch)
treecf25eed5beb574890c57de149e8a987adf52e62f /sys-apps/timer_entropyd
parentapp-misc/abook: EAPI 6 bump. (diff)
downloadgentoo-cc0a6ca146a0bec4827da69f5ddb60e12c02f181.tar.gz
gentoo-cc0a6ca146a0bec4827da69f5ddb60e12c02f181.tar.bz2
gentoo-cc0a6ca146a0bec4827da69f5ddb60e12c02f181.zip
sys-apps/timer_entropyd: Bump to 0.3 and use EAPI5, update copyright.
Signed-off-by: Joshua Kinard <kumba@gentoo.org> Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-apps/timer_entropyd')
-rw-r--r--sys-apps/timer_entropyd/Manifest1
-rw-r--r--sys-apps/timer_entropyd/timer_entropyd-0.2.ebuild2
-rw-r--r--sys-apps/timer_entropyd/timer_entropyd-0.3.ebuild42
3 files changed, 44 insertions, 1 deletions
diff --git a/sys-apps/timer_entropyd/Manifest b/sys-apps/timer_entropyd/Manifest
index c949a3a62587..6efb9562f40d 100644
--- a/sys-apps/timer_entropyd/Manifest
+++ b/sys-apps/timer_entropyd/Manifest
@@ -1 +1,2 @@
DIST timer_entropyd-0.2.tgz 8323 SHA256 0cf2b976b78c1b1169a4bec5a6fc71d8b118de927bc05002686376a61f73989a SHA512 789f19c2652781593b9ce91c584eab4ef9210bb47f1afb6186311416a67c84235ed1a163ffdc017b6d50ff706bf7ff6a84013b4b31fe6c09eabe95a484805898 WHIRLPOOL 8fa8233d8a867f7f5290ba1fbd39a2ed80756cfe0948fcc5038c256b4f62b39bd1592a639e6c13ce11c481a9a85288dd30568fd082c36bd09f6ad5986c421d15
+DIST timer_entropyd-0.3.tgz 8329 SHA256 3a022b82363c3ecdd005cd6c5a7441d62a46aa88059581c2f7677bd84f393560 SHA512 bdfedb594ee32daf7fb961a703842ca3479de158fc19bd75664b183e44bcf2ef3e74645cc6097f340834933db6f9133710df7d433ac062b2375494de5c052dcc WHIRLPOOL 8806784ffc7ce6c370d15980dfe00e4afd89dcfdfd2d06b5eb9f8d9d8b46e4974d429e93703fb26ad9ade4b5d53c2c25c88356b31aec08ed16340711d1025142
diff --git a/sys-apps/timer_entropyd/timer_entropyd-0.2.ebuild b/sys-apps/timer_entropyd/timer_entropyd-0.2.ebuild
index d4026f8b28c0..2b3bcbaaca69 100644
--- a/sys-apps/timer_entropyd/timer_entropyd-0.2.ebuild
+++ b/sys-apps/timer_entropyd/timer_entropyd-0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
diff --git a/sys-apps/timer_entropyd/timer_entropyd-0.3.ebuild b/sys-apps/timer_entropyd/timer_entropyd-0.3.ebuild
new file mode 100644
index 000000000000..d1a0febbc6a9
--- /dev/null
+++ b/sys-apps/timer_entropyd/timer_entropyd-0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A timer-based entropy generator"
+HOMEPAGE="http://www.vanheusden.com/te/"
+SRC_URI="http://www.vanheusden.com/te/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="debug selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-entropyd )"
+
+src_prepare() {
+ sed -i -e 's:-O2::' Makefile || die
+ epatch "${FILESDIR}"/${PN}-0.1-syslog.patch
+}
+
+src_compile() {
+ use debug && append-cppflags -D_DEBUG
+
+ tc-export CC
+ emake DEBUG= || die
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe ${PN}
+ dodoc Changes readme.txt
+ newinitd "${FILESDIR}/timer_entropyd.initd.1" ${PN} || die
+}
+
+pkg_postinst() {
+ elog "To start ${PN} at boot do rc-update add ${PN} default"
+ elog "To start ${PN} now do /etc/init.d/${PN} start"
+ elog "To check the amount of entropy, cat /proc/sys/kernel/random/entropy_avail"
+}