summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKapil Porwal <107070036+kapil-porwal@users.noreply.github.com>2023-02-22 15:18:38 +0530
committerSam James <sam@gentoo.org>2023-03-19 03:29:27 +0000
commit8cfb2386afa1b59ffd40577048fd51e35065f125 (patch)
tree79ce238ac49862834885c206252d7dbb40df0e02 /sys-apps
parentnet-nds/openldap: add LTS note (diff)
downloadgentoo-8cfb2386afa1b59ffd40577048fd51e35065f125.tar.gz
gentoo-8cfb2386afa1b59ffd40577048fd51e35065f125.tar.bz2
gentoo-8cfb2386afa1b59ffd40577048fd51e35065f125.zip
sys-apps/dmidecode: Enable LFS
The Makefile for this application is adding "_FILE_OFFSET_BITS=64" to the CFLAGS but the ebuild seems to be overriding it. Signed-off-by: Kapil Porwal <107070036+kapil-porwal@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/29717 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dmidecode/dmidecode-3.4-r1.ebuild (renamed from sys-apps/dmidecode/dmidecode-3.4.ebuild)2
-rw-r--r--sys-apps/dmidecode/dmidecode-3.5-r1.ebuild (renamed from sys-apps/dmidecode/dmidecode-3.5.ebuild)2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-apps/dmidecode/dmidecode-3.4.ebuild b/sys-apps/dmidecode/dmidecode-3.4-r1.ebuild
index 82a023f12031..92d65b193d64 100644
--- a/sys-apps/dmidecode/dmidecode-3.4.ebuild
+++ b/sys-apps/dmidecode/dmidecode-3.4-r1.ebuild
@@ -30,7 +30,7 @@ src_prepare() {
src_compile() {
emake \
- CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CFLAGS="-D_FILE_OFFSET_BITS=64 ${CFLAGS} ${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
CC="$(tc-getCC)"
}
diff --git a/sys-apps/dmidecode/dmidecode-3.5.ebuild b/sys-apps/dmidecode/dmidecode-3.5-r1.ebuild
index fd9962c60623..07d8528c8c98 100644
--- a/sys-apps/dmidecode/dmidecode-3.5.ebuild
+++ b/sys-apps/dmidecode/dmidecode-3.5-r1.ebuild
@@ -30,7 +30,7 @@ src_prepare() {
src_compile() {
emake \
- CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CFLAGS="-D_FILE_OFFSET_BITS=64 ${CFLAGS} ${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
CC="$(tc-getCC)"
}