summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/pam-csync
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/pam-csync')
-rw-r--r--sys-auth/pam-csync/Manifest1
-rw-r--r--sys-auth/pam-csync/files/pam-csync-0.42.0-cmake.patch25
-rw-r--r--sys-auth/pam-csync/files/pam-csync-0.42.0-ocsync.patch33
-rw-r--r--sys-auth/pam-csync/metadata.xml7
-rw-r--r--sys-auth/pam-csync/pam-csync-0.42.0-r1.ebuild32
5 files changed, 98 insertions, 0 deletions
diff --git a/sys-auth/pam-csync/Manifest b/sys-auth/pam-csync/Manifest
new file mode 100644
index 000000000000..3ddef839ee5c
--- /dev/null
+++ b/sys-auth/pam-csync/Manifest
@@ -0,0 +1 @@
+DIST pam_csync-0.42.0.tar.gz 30457 SHA256 bba01854ee5929ecc90428275a50f804d361e92f2805f1d2eff7d3f2bca48802 SHA512 ef6d0fbadf6afdf5a5adad1905e976330506fdf60835aa4190959b855fbc2c4c61bd709fe2aaaab731ec5430c999b3fd5e23f3a81c35a7b266b23cd092d24e06 WHIRLPOOL b81a0a9ad1e0188856cc6ffc265c44cc67a3603fb550bc59c4aa8a63198a9898d389238a7582c439add1528eaba6bf2aa930d65dd3429c901d9e6b3ecb2328ac
diff --git a/sys-auth/pam-csync/files/pam-csync-0.42.0-cmake.patch b/sys-auth/pam-csync/files/pam-csync-0.42.0-cmake.patch
new file mode 100644
index 000000000000..2b650d232e2a
--- /dev/null
+++ b/sys-auth/pam-csync/files/pam-csync-0.42.0-cmake.patch
@@ -0,0 +1,25 @@
+From 21dfcf6343cec2feb0e4ebd8b9e22a3aa39e5d9d Mon Sep 17 00:00:00 2001
+From: Jim McDonough <jmcd@samba.org>
+Date: Mon, 10 Mar 2014 10:16:28 -0400
+Subject: [PATCH 1/2] Remove backward compatibility option for newer cmake
+ builds to work.
+
+---
+ src/CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 6732a3f..40225e4 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -41,7 +41,6 @@ include_directories(
+ ${PAM_CSYNC_PRIVATE_INCLUDE_DIRS}
+ )
+
+-set(CMAKE_BACKWARDS_COMPATIBILITY "2.2")
+ macro_add_plugin(${PAM_CSYNC_LIBRARY} ${pam_SRCS})
+
+ target_link_libraries(${PAM_CSYNC_LINK_LIBRARIES})
+--
+1.8.4.5
+
diff --git a/sys-auth/pam-csync/files/pam-csync-0.42.0-ocsync.patch b/sys-auth/pam-csync/files/pam-csync-0.42.0-ocsync.patch
new file mode 100644
index 000000000000..117a2b0db26f
--- /dev/null
+++ b/sys-auth/pam-csync/files/pam-csync-0.42.0-ocsync.patch
@@ -0,0 +1,33 @@
+Since 0.60.0, upstream renamed to "ocsync".
+
+--- cmake/Modules/FindCSYNC.cmake
++++ cmake/Modules/FindCSYNC.cmake
+@@ -20,7 +20,7 @@
+ else (CSYNC_LIBRARIES AND CSYNC_INCLUDE_DIRS)
+ find_path(CSYNC_INCLUDE_DIR
+ NAMES
+- csync/csync.h
++ ocsync/csync.h
+ PATHS
+ /usr/include
+ /usr/local/include
+@@ -30,7 +30,7 @@
+
+ find_library(CSYNC_LIBRARY
+ NAMES
+- csync
++ ocsync
+ PATHS
+ /usr/lib
+ /usr/local/lib
+--- src/pam_csync.c
++++ src/pam_csync.c
+@@ -50,7 +50,7 @@
+ #include <security/pam_modutil.h>
+ #include <security/pam_ext.h>
+
+-#include <csync/csync.h>
++#include <ocsync/csync.h>
+
+ #include "pam_csync.h"
+ #include "config.h"
diff --git a/sys-auth/pam-csync/metadata.xml b/sys-auth/pam-csync/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/sys-auth/pam-csync/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-auth/pam-csync/pam-csync-0.42.0-r1.ebuild b/sys-auth/pam-csync/pam-csync-0.42.0-r1.ebuild
new file mode 100644
index 000000000000..52c4b9a89d5a
--- /dev/null
+++ b/sys-auth/pam-csync/pam-csync-0.42.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="PAM module to provide roaming home directories for a user session"
+HOMEPAGE="http://www.csync.org/"
+SRC_URI="http://www.csync.org/files/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/iniparser-3.1
+ >=net-misc/ocsync-0.60.0
+ virtual/pam
+"
+DEPEND="${DEPEND}
+ app-text/asciidoc
+"
+
+S="${WORKDIR}/${P/-/_}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${P}-ocsync.patch"
+)