summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-22 13:07:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-22 13:16:44 +0100
commit11b0c540fe09a099d51ed0a63273d91a2c587e21 (patch)
treec90c05acd922d5c7ed0b77ac9b047acd80d3a0a5 /sys-auth/polkit-qt
parentdev-libs/libdbusmenu-qt: Drop USE=qt4, cmake-multilib and multibuild (diff)
downloadgentoo-11b0c540fe09a099d51ed0a63273d91a2c587e21.tar.gz
gentoo-11b0c540fe09a099d51ed0a63273d91a2c587e21.tar.bz2
gentoo-11b0c540fe09a099d51ed0a63273d91a2c587e21.zip
sys-auth/polkit-qt: Drop USE=qt4 and multibuild
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-auth/polkit-qt')
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.112.0_p20160416-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-auth/polkit-qt/polkit-qt-0.112.0_p20160416-r2.ebuild b/sys-auth/polkit-qt/polkit-qt-0.112.0_p20160416-r2.ebuild
new file mode 100644
index 000000000000..e909e08a5bfd
--- /dev/null
+++ b/sys-auth/polkit-qt/polkit-qt-0.112.0_p20160416-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P/qt/qt-1}"
+inherit cmake-utils
+
+DESCRIPTION="PolicyKit Qt API wrapper library"
+HOMEPAGE="https://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/"
+SRC_URI="https://dev.gentoo.org/~kensington/distfiles/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug examples"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=sys-auth/polkit-0.103
+ examples? ( dev-qt/qtxml:5 )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README README.porting TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DUSE_QT4=OFF
+ -DUSE_QT5=ON
+ )
+
+ cmake-utils_src_configure
+}