summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/di
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/di')
-rw-r--r--sys-block/di/Manifest2
-rw-r--r--sys-block/di/di-4.35.ebuild37
-rw-r--r--sys-block/di/di-4.36.ebuild37
-rw-r--r--sys-block/di/files/di-4.33-build.patch40
-rw-r--r--sys-block/di/metadata.xml5
5 files changed, 121 insertions, 0 deletions
diff --git a/sys-block/di/Manifest b/sys-block/di/Manifest
new file mode 100644
index 000000000000..a159789e5748
--- /dev/null
+++ b/sys-block/di/Manifest
@@ -0,0 +1,2 @@
+DIST di-4.35.tar.gz 212325 SHA256 2cdfface7a85e3a359cb228277b090a0648cabe18520e43b09919bdaf67b71d2 SHA512 5b7e7bd347b1ea285c4410e864f29cf475015a560baf450e558d3f8e1994b10822d6c3e18c04447c6a229d6d5e991194a4a3b155f3b36a8acfee866c8d048cec WHIRLPOOL 2891f70976f5818aa73ec3a07dc4afda678ae02c63b5a018cfb538a78d25f0432d70a7104ef1fe5f6e23e8e5f301430f4cc39b1538a83ea35d1a4748d4e55929
+DIST di-4.36.tar.gz 212957 SHA256 eb03d2ac0a3df531cdcb64b3667dbaebede60a4d3a4626393639cecb954c6d86 SHA512 ce7d38d3e23e68caa70bc85b623b7f4f633e2abf11b5df66b7104be49f1a1b2e64754d51ed00dd9ae629409e2a4760424f781e0351697b077e6aafb64bedad78 WHIRLPOOL 8f2c486d02dbe3f41d74d8a4e1df006ef0fa690bd0e5f3d71c6c47813724a899088fe51da2cdbb5407c27626949b1d048dc0bc1f20a8d964288c0abd8bbdb058
diff --git a/sys-block/di/di-4.35.ebuild b/sys-block/di/di-4.35.ebuild
new file mode 100644
index 000000000000..fd98e770a081
--- /dev/null
+++ b/sys-block/di/di-4.35.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Disk Information Utility"
+HOMEPAGE="http://www.gentoo.com/di/"
+SRC_URI="http://www.gentoo.com/di/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+RESTRICT="test" #405205, #405471
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.33-build.patch
+}
+
+src_configure() {
+ emake checkbuild
+ emake -C C config.h
+}
+
+src_compile() {
+ emake prefix=/usr CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake install prefix="${D}/usr"
+ # default symlink is broken
+ dosym di /usr/bin/mi
+ dodoc README
+}
diff --git a/sys-block/di/di-4.36.ebuild b/sys-block/di/di-4.36.ebuild
new file mode 100644
index 000000000000..5b4dc01395aa
--- /dev/null
+++ b/sys-block/di/di-4.36.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Disk Information Utility"
+HOMEPAGE="http://www.gentoo.com/di/"
+SRC_URI="http://www.gentoo.com/di/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RESTRICT="test" #405205, #405471
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.33-build.patch
+}
+
+src_configure() {
+ emake checkbuild
+ emake -C C config.h
+}
+
+src_compile() {
+ emake prefix=/usr CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake install prefix="${D}/usr"
+ # default symlink is broken
+ dosym di /usr/bin/mi
+ dodoc README
+}
diff --git a/sys-block/di/files/di-4.33-build.patch b/sys-block/di/files/di-4.33-build.patch
new file mode 100644
index 000000000000..adefb4993885
--- /dev/null
+++ b/sys-block/di/files/di-4.33-build.patch
@@ -0,0 +1,40 @@
+These are the first errors occuring:
+
+di.h:82:4: error: unknown type name ‘error’
+di.h:82:19: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘/’ token
+di.h:143:5: error: unknown type name ‘_fs_size_t’
+
+Then there is a lot more errors after above.
+
+memcpy can't be detected normally due to:
+ http://gcc.gnu.org/PR55890
+
+--- C/di.h
++++ C/di.h
+@@ -9,6 +9,8 @@
+
+ #include "config.h"
+
++#include <string.h>
++
+ /*****************************************************/
+
+ #include <stdio.h>
+@@ -79,7 +81,7 @@
+
+ #if ! _lib_memcpy && ! _define_memcpy
+ # if ! _lib_bcopy && ! _define_bcopy
+- #error No_memcpy/bcopy_available.
++ //#error No_memcpy/bcopy_available.
+ # else
+ # define memcpy(dst, src, cnt) (bcopy((src), (dst), (cnt)), dst)
+ # endif
+@@ -87,7 +89,7 @@
+
+ #if ! _lib_memset && ! _define_memset
+ # if ! _lib_bzero && ! _define_bzero
+- #error No_memset/bzero_available.
++ //#error No_memset/bzero_available.
+ # else
+ # define memset(s,c,n) (bzero ((s), (n)), s)
+ # endif
diff --git a/sys-block/di/metadata.xml b/sys-block/di/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-block/di/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>