summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-09-13 16:48:54 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-09-13 16:49:27 -0700
commitbb07f65ed157020b4c7ebea9557820f5148d8920 (patch)
treea738ca223161825adce24ff2bba9a6299af25b73 /sys-cluster/ceph
parentwww-client/vivaldi: Drop old 6.2.3105.45 (diff)
downloadgentoo-bb07f65ed157020b4c7ebea9557820f5148d8920.tar.gz
gentoo-bb07f65ed157020b4c7ebea9557820f5148d8920.tar.bz2
gentoo-bb07f65ed157020b4c7ebea9557820f5148d8920.zip
sys-cluster/ceph: Revbumps, add patch to build with cython-3
Closes: https://bugs.gentoo.org/907739 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ceph-16.2.14-r1.ebuild (renamed from sys-cluster/ceph/ceph-16.2.14.ebuild)4
-rw-r--r--sys-cluster/ceph/ceph-17.2.6-r8.ebuild (renamed from sys-cluster/ceph/ceph-17.2.6-r7.ebuild)4
-rw-r--r--sys-cluster/ceph/ceph-18.2.0-r2.ebuild (renamed from sys-cluster/ceph/ceph-18.2.0-r1.ebuild)5
-rw-r--r--sys-cluster/ceph/files/ceph-18.2.0-cython3.patch26
4 files changed, 35 insertions, 4 deletions
diff --git a/sys-cluster/ceph/ceph-16.2.14.ebuild b/sys-cluster/ceph/ceph-16.2.14-r1.ebuild
index c62e195e159e..40f04bb1347a 100644
--- a/sys-cluster/ceph/ceph-16.2.14.ebuild
+++ b/sys-cluster/ceph/ceph-16.2.14-r1.ebuild
@@ -103,7 +103,7 @@ BDEPEND="
x86? ( dev-lang/yasm )
app-arch/cpio
>=dev-util/cmake-3.5.0
- <dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx
dev-util/gperf
@@ -213,6 +213,8 @@ PATCHES=(
"${FILESDIR}/ceph-16.2.10-flags.patch"
"${FILESDIR}/ceph-17.2.5-boost-1.81.patch"
"${FILESDIR}/ceph-16.2.14-gcc13.patch"
+ # https://bugs.gentoo.org/907739
+ "${FILESDIR}/ceph-18.2.0-cython3.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/ceph-17.2.6-r7.ebuild b/sys-cluster/ceph/ceph-17.2.6-r8.ebuild
index 2a2b757517dd..3f4382b4cbef 100644
--- a/sys-cluster/ceph/ceph-17.2.6-r7.ebuild
+++ b/sys-cluster/ceph/ceph-17.2.6-r8.ebuild
@@ -110,7 +110,7 @@ BDEPEND="
x86? ( dev-lang/yasm )
app-arch/cpio
>=dev-util/cmake-3.5.0
- <dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx
dev-util/gperf
@@ -226,6 +226,8 @@ PATCHES=(
"${FILESDIR}/ceph-17.2.6-arrow-flatbuffers-c++14.patch"
# https://bugs.gentoo.org/868891
"${FILESDIR}/ceph-17.2.6-cmake.patch"
+ # https://bugs.gentoo.org/907739
+ "${FILESDIR}/ceph-18.2.0-cython3.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/ceph-18.2.0-r1.ebuild b/sys-cluster/ceph/ceph-18.2.0-r2.ebuild
index c24704db3311..72743d105137 100644
--- a/sys-cluster/ceph/ceph-18.2.0-r1.ebuild
+++ b/sys-cluster/ceph/ceph-18.2.0-r2.ebuild
@@ -107,13 +107,12 @@ DEPEND="
zbd? ( sys-block/libzbd:= )
zfs? ( sys-fs/zfs:= )
"
-# <cython-3: bug #907739
BDEPEND="
amd64? ( dev-lang/nasm )
x86? ( dev-lang/yasm )
app-arch/cpio
>=dev-util/cmake-3.5.0
- <dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx
dev-util/gperf
@@ -224,6 +223,8 @@ PATCHES=(
# https://bugs.gentoo.org/868891
"${FILESDIR}/ceph-17.2.6-cmake.patch"
"${FILESDIR}/ceph-18.2.0-cyclic-deps.patch"
+ # https://bugs.gentoo.org/907739
+ "${FILESDIR}/ceph-18.2.0-cython3.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/files/ceph-18.2.0-cython3.patch b/sys-cluster/ceph/files/ceph-18.2.0-cython3.patch
new file mode 100644
index 000000000000..bfaeacea4f26
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-18.2.0-cython3.patch
@@ -0,0 +1,26 @@
+diff --git a/src/pybind/rbd/rbd.pyx b/src/pybind/rbd/rbd.pyx
+index 5e14e38c919..d10dce62262 100644
+--- a/src/pybind/rbd/rbd.pyx
++++ b/src/pybind/rbd/rbd.pyx
+@@ -371,10 +371,10 @@ ELSE:
+ cdef rados_ioctx_t convert_ioctx(rados.Ioctx ioctx) except? NULL:
+ return <rados_ioctx_t>ioctx.io
+
+-cdef int progress_callback(uint64_t offset, uint64_t total, void* ptr) with gil:
++cdef int progress_callback(uint64_t offset, uint64_t total, void* ptr) noexcept with gil:
+ return (<object>ptr)(offset, total)
+
+-cdef int no_op_progress_callback(uint64_t offset, uint64_t total, void* ptr):
++cdef int no_op_progress_callback(uint64_t offset, uint64_t total, void* ptr) noexcept with gil:
+ return 0
+
+ def cstr(val, name, encoding="utf-8", opt=False):
+@@ -426,7 +426,7 @@ RBD_MIRROR_PEER_ATTRIBUTE_NAME_KEY = decode_cstr(_RBD_MIRROR_PEER_ATTRIBUTE_NAME
+
+ cdef class Completion
+
+-cdef void __aio_complete_cb(rbd_completion_t completion, void *args) with gil:
++cdef void __aio_complete_cb(rbd_completion_t completion, void *args) noexcept with gil:
+ """
+ Callback to oncomplete() for asynchronous operations
+ """