summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Rothenpieler <btbn@btbn.de>2020-07-24 21:25:11 +0200
committerAlexys Jacob <ultrabug@gentoo.org>2020-10-21 14:58:08 +0200
commit3d396e796a9b307764e8d200ee0558b29a302213 (patch)
tree0b9d7cba3f003b5438090153992cc00b8c15c751 /sys-cluster
parentsys-cluster/resource-agents: bump for 4.6.1 (diff)
downloadgentoo-3d396e796a9b307764e8d200ee0558b29a302213.tar.gz
gentoo-3d396e796a9b307764e8d200ee0558b29a302213.tar.bz2
gentoo-3d396e796a9b307764e8d200ee0558b29a302213.zip
sys-cluster/kronosnet: add new corosync dependency
Closes: https://bugs.gentoo.org/596882 Signed-off-by: Timo Rothenpieler <btbn@btbn.de> Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/kronosnet/Manifest1
-rw-r--r--sys-cluster/kronosnet/kronosnet-1.19.ebuild55
-rw-r--r--sys-cluster/kronosnet/metadata.xml16
3 files changed, 72 insertions, 0 deletions
diff --git a/sys-cluster/kronosnet/Manifest b/sys-cluster/kronosnet/Manifest
new file mode 100644
index 000000000000..c5eb97255671
--- /dev/null
+++ b/sys-cluster/kronosnet/Manifest
@@ -0,0 +1 @@
+DIST kronosnet-1.19.tar.xz 461952 BLAKE2B ea6da6c760d73eb3d0b24827d019b479fe2d021f1eea8cb0e0497b390c04b64f99802159e61b1a8b26f38da542cbd52987504cb7c667a9b22ecb53b2fffdf20f SHA512 32b9d7254e9cf5768648aafe5cb019105e247edc1b8a427cc4e655ab4bd9d6a44614f67ba2ac4779f4d11d829d86e6fb8ceb27838dbb44bcefc351db76a41705
diff --git a/sys-cluster/kronosnet/kronosnet-1.19.ebuild b/sys-cluster/kronosnet/kronosnet-1.19.ebuild
new file mode 100644
index 000000000000..b3a36ea3ccef
--- /dev/null
+++ b/sys-cluster/kronosnet/kronosnet-1.19.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Network abstraction layer designed for High Availability use cases"
+HOMEPAGE="https://kronosnet.org"
+SRC_URI="https://kronosnet.org/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc nss +openssl zstd lz4 lzo2"
+
+DEPEND=">=sys-cluster/libqb-2.0.0:=
+ dev-libs/libnl:3
+ sys-libs/zlib:=
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ zstd? ( app-arch/zstd:= )
+ lzo2? ( dev-libs/lzo:2 )
+ lz4? ( app-arch/lz4:= )
+ nss? ( dev-libs/nss )
+ openssl? ( dev-libs/openssl:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? (
+ >=sys-cluster/libqb-2.0.0
+ app-doc/doxygen[dot]
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf_opts=(
+ $(use_enable doc man) \
+ --disable-static \
+ --enable-libnozzle \
+ --disable-libknet-sctp \
+ --enable-compress-zlib \
+ --enable-compress-bzip2 \
+ --enable-compress-lzma \
+ $(use_enable nss crypto-nss) \
+ $(use_enable openssl crypto-openssl) \
+ $(use_enable zstd compress-zstd) \
+ $(use_enable lz4 compress-lz4) \
+ $(use_enable lzo2 compress-lzo2)
+ )
+ econf "${econf_opts[@]}"
+}
diff --git a/sys-cluster/kronosnet/metadata.xml b/sys-cluster/kronosnet/metadata.xml
new file mode 100644
index 000000000000..3c1e39beaec8
--- /dev/null
+++ b/sys-cluster/kronosnet/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kronosnet/kronosnet</remote-id>
+ </upstream>
+ <use>
+ <flag name="nss">Add support for tls via nss</flag>
+ <flag name="openssl">Add support for tls via openssl</flag>
+ <flag name="lzo2">Add support for lzo2 compression</flag>
+ </use>
+</pkgmetadata>