summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-08-21 11:47:07 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-08-21 11:48:10 -0500
commit67f6485c888473f54f63e2d5eeda5bb7db105a1b (patch)
treee76b085a6204ec190721dd8d412e9ee3f6e25da0 /sys-cluster
parentsys-cluster/nomad: restrict tests (diff)
downloadgentoo-67f6485c888473f54f63e2d5eeda5bb7db105a1b.tar.gz
gentoo-67f6485c888473f54f63e2d5eeda5bb7db105a1b.tar.bz2
gentoo-67f6485c888473f54f63e2d5eeda5bb7db105a1b.zip
sys-cluster/nomad: remove old
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/nomad/Manifest1
-rw-r--r--sys-cluster/nomad/nomad-0.12.1.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/sys-cluster/nomad/Manifest b/sys-cluster/nomad/Manifest
index a9f60d910a4d..f6174e5dded7 100644
--- a/sys-cluster/nomad/Manifest
+++ b/sys-cluster/nomad/Manifest
@@ -1,2 +1 @@
-DIST nomad-0.12.1.tar.gz 51227967 BLAKE2B 1354641dfcfd4d3fca44261792f65ca117be77aaf0d5a028e424b5ced2c14c1cc5e82a8dcac587c3fcb7796e8e260bee8b65fcf202ddd3b766f96373e996a874 SHA512 cbb6b2b89f4922108d10c832638460ad2b234fdfd95e61aa57fb5d89f9852dca1a42527bfd7cbcb166916394b38d7d6451c8f5fd2e56b02599926209e395d9e2
DIST nomad-0.12.3.tar.gz 51432205 BLAKE2B 77090f387e25f226c8d05b6ea16abfac0f4b710a40a3e7e5455bd6c8b7992080980967d4ebb92257348968dddbb45d2e5c3b58f143ae1205742bf08f0dec2a71 SHA512 17d361db11104ddbbae12a17301005c8eca3650e3fdda8f2fd6db8474728f31a2b6f828f2fba7e7d9d132b08cfb070799273353a17f5f66baa4dc5a0492562f8
diff --git a/sys-cluster/nomad/nomad-0.12.1.ebuild b/sys-cluster/nomad/nomad-0.12.1.ebuild
deleted file mode 100644
index f51d35a6474b..000000000000
--- a/sys-cluster/nomad/nomad-0.12.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module systemd
-GIT_COMMIT=00263bf92ee3fe7964fbc08b150600a43df0abb8
-
-DESCRIPTION="A simple and flexible workload orchestrator "
-HOMEPAGE="https://nomadproject.io"
-SRC_URI="https://github.com/hashicorp/nomad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-src_compile() {
- local go_ldflags go_tags
- go_ldflags="-X github.com/hashicorp/nomad/version.GitCommit=${GIT_COMMIT}"
- go_tags="codegen_generated"
- CGO_ENABLED=1 \
- go build \
- -trimpath \
- -ldflags "${go_ldflags}" \
- -mod=vendor \
- -tags "${go_tags}" \
- -o bin/${PN} || die "compile failed"
-}
-
-src_install() {
- dobin bin/${PN}
- systemd_dounit dist/systemd/nomad.service
- insinto /etc/nomad.d
- newins dist/client.hcl client.hcl.example
- newins dist/server.hcl server.hcl.example
- keepdir /var/lib/nomad /var/log/nomad
- newconfd "${FILESDIR}/nomad.confd" nomad
- newinitd "${FILESDIR}/nomad.initd" nomad
- insinto /etc/logrotate.d
- newins "${FILESDIR}/nomad.logrotated" nomad
-}