summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-15 00:36:37 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-15 00:38:54 +0200
commit98f46d0de5bc6d9d608e3453c8e435d2e49e1a65 (patch)
tree7965110e77b035f45c82b0b2a95aa21db49dd6e4 /sys-devel/clang
parentsys-devel/llvm: Fix passing -DNDEBUG to build, #614844 (diff)
downloadgentoo-98f46d0de5bc6d9d608e3453c8e435d2e49e1a65.tar.gz
gentoo-98f46d0de5bc6d9d608e3453c8e435d2e49e1a65.tar.bz2
gentoo-98f46d0de5bc6d9d608e3453c8e435d2e49e1a65.zip
sys-devel/clang: Fix passing -DNDEBUG to build, #614844
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-4.0.0-r2.ebuild (renamed from sys-devel/clang/clang-4.0.0-r1.ebuild)2
-rw-r--r--sys-devel/clang/clang-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-4.0.0-r1.ebuild b/sys-devel/clang/clang-4.0.0-r2.ebuild
index eaf9b27e3c51..a127f9c864f8 100644
--- a/sys-devel/clang/clang-4.0.0-r1.ebuild
+++ b/sys-devel/clang/clang-4.0.0-r2.ebuild
@@ -206,6 +206,8 @@ multilib_src_configure() {
)
fi
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake-utils_src_configure
}
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 05f378ffda76..9987f2bfa1af 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -209,6 +209,8 @@ multilib_src_configure() {
)
fi
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake-utils_src_configure
}