summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-26 08:29:22 +0000
committerSam James <sam@gentoo.org>2022-12-26 08:33:04 +0000
commit36a91459098d29de88e6218783d942d868ad869f (patch)
tree34bf9c525cb7edadd374edc1f241c0a9691866ba /sys-fs/dd-rescue
parentsys-devel/gnuconfig: drop 20220508 (diff)
downloadgentoo-36a91459098d29de88e6218783d942d868ad869f.tar.gz
gentoo-36a91459098d29de88e6218783d942d868ad869f.tar.bz2
gentoo-36a91459098d29de88e6218783d942d868ad869f.zip
sys-fs/dd-rescue: drop 1.99.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/dd-rescue')
-rw-r--r--sys-fs/dd-rescue/Manifest1
-rw-r--r--sys-fs/dd-rescue/dd-rescue-1.99.11.ebuild105
-rw-r--r--sys-fs/dd-rescue/files/dd-rescue-1.99.11-musl-r2.patch30
3 files changed, 0 insertions, 136 deletions
diff --git a/sys-fs/dd-rescue/Manifest b/sys-fs/dd-rescue/Manifest
index a2fbbbd2380c..0e9690fb61e1 100644
--- a/sys-fs/dd-rescue/Manifest
+++ b/sys-fs/dd-rescue/Manifest
@@ -1,2 +1 @@
-DIST dd_rescue-1.99.11.tar.bz2 181927 BLAKE2B 8cd4db6cb8d85962e4cea50b0006fdbe5f085fbcf7bdbfe4d0fab1fe33412c1379317f54429c76ed1d905e32d5e791869fa27f2f14917cb1c3842fc6caca2a12 SHA512 e1d32711421ebbafd80fd210718667ff8c2d22b5349945105b3e4c29d54d381385b1fd188b2d8aa1b7a0aaf2cc9d8f7374373cff3992726a3d17549ca50f3904
DIST dd_rescue-1.99.12.tar.bz2 181798 BLAKE2B 547910af7ac5dde360179dbd75bed36e6420dda162a41f9bb60a454f5c6629d6a1be9b15240ce3d0e7b80e09c660a87765e826909614b037a506ad775b71041f SHA512 61f4f09e7e8442049634c5a5659f887cf82b16bc8b768c0aa79774e18feac6e91fbc258e5a6c8c3cac0577fadbdd26206261cf6c99b3980f763a1b584fb46001
diff --git a/sys-fs/dd-rescue/dd-rescue-1.99.11.ebuild b/sys-fs/dd-rescue/dd-rescue-1.99.11.ebuild
deleted file mode 100644
index 29ab8a745124..000000000000
--- a/sys-fs/dd-rescue/dd-rescue-1.99.11.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic multilib toolchain-funcs
-
-MY_PN="${PN/-/_}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Similar to dd but can copy from source with errors"
-HOMEPAGE="http://www.garloff.de/kurt/linux/ddrescue/"
-SRC_URI="http://www.garloff.de/kurt/linux/ddrescue/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~mips ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="cpu_flags_x86_avx2 lzo cpu_flags_x86_sse4_2 static xattr"
-
-RDEPEND="lzo? ( dev-libs/lzo )
- xattr? ( sys-apps/attr )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.99.11-musl-r2.patch
-)
-
-src_prepare() {
- default
-
- if ! use cpu_flags_x86_sse4_2; then
- sed -i \
- -e 's:^CC_FLAGS_CHECK(-msse4.2,SSE42):#&:' \
- configure.ac || die
- fi
-
- if ! use cpu_flags_x86_avx2; then
- sed -i \
- -e 's:^CC_FLAGS_CHECK(-mavx2,AVX2):#&:' \
- configure.ac || die
- fi
-
- eautoreconf
-
- sed -i \
- -e 's:\(-ldl\):$(LDFLAGS) \1:' \
- -e 's:\(-shared\):$(CFLAGS) $(LDFLAGS) \1:' \
- Makefile || die
-}
-
-src_configure() {
- use static && append-ldflags -static
- # OpenSSL is only used by a random helper tool we don't install.
- ac_cv_header_attr_xattr_h=$(usex xattr) \
- ac_cv_header_openssl_evp_h=no \
- ac_cv_lib_crypto_EVP_aes_192_ctr=no \
- ac_cv_lib_lzo2_lzo1x_1_compress=$(usex lzo) \
- ac_cv_header_lzo_lzo1x_h=$(usex lzo) \
- econf
-}
-
-_emake() {
- local arch
- case ${ARCH} in
- x86) arch=i386;;
- amd64) arch=x86_64;;
- arm) arch=arm;;
- arm64) arch=aarch64;;
- esac
-
- local os=$(usex kernel_linux Linux IDK)
-
- # The Makefile is a mess. Override a few vars rather than patch it.
- emake \
- MACH="${arch}" \
- OS="${os}" \
- HAVE_SSE42=$(usex cpu_flags_x86_sse4_2 1 0) \
- HAVE_AVX2=$(usex cpu_flags_x86_avx2 1 0) \
- RPM_OPT_FLAGS="${CFLAGS} ${CPPFLAGS}" \
- CFLAGS_OPT='$(CFLAGS)' \
- LDFLAGS="${LDFLAGS} -Wl,-rpath,${EPREFIX}/usr/$(get_libdir)/${PN}" \
- CC="$(tc-getCC)" \
- "$@"
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- append-cflags -fcommon # bug 707796
- _emake check
-}
-
-src_install() {
- # easier to install by hand than trying to make sense of the Makefile.
- dobin dd_rescue
- dodir /usr/$(get_libdir)/${PN}
- cp -pPR libddr_*.so "${ED}"/usr/$(get_libdir)/${PN}/ || die
- dodoc README.dd_rescue
- doman dd_rescue.1
- use lzo && doman ddr_lzo.1
-}
diff --git a/sys-fs/dd-rescue/files/dd-rescue-1.99.11-musl-r2.patch b/sys-fs/dd-rescue/files/dd-rescue-1.99.11-musl-r2.patch
deleted file mode 100644
index d88649d65eae..000000000000
--- a/sys-fs/dd-rescue/files/dd-rescue-1.99.11-musl-r2.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 69c3974670f5a8ee0f2258f10a9228b39025b464 Mon Sep 17 00:00:00 2001
-From: Thomas Deutschmann <whissi@gentoo.org>
-Date: Wed, 13 Dec 2017 01:02:12 +0100
-Subject: [PATCH] loff_t and __WORDSIZE includes for MUSL
-
-Rewrite of Justin Keogh's patch [Link 1] to fix build problems
-on ARM.
-
-Link 1: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5f5abc0f1b036921d6eb5b0f434c960ed280619f
-Fixes: https://bugs.gentoo.org/616364
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 7332da8..ef2016a 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -11,7 +11,7 @@ AC_C_INLINE
-
- #AC_PROG_INSTALL
- #CFLAGS="$CFLAGS -DHAVE_CONFIG_H"
--AC_CHECK_HEADERS([fallocate.h dlfcn.h unistd.h sys/xattr.h attr/xattr.h sys/acl.h sys/ioctl.h endian.h linux/fs.h linux/fiemap.h stdint.h lzo/lzo1x.h openssl/evp.h linux/random.h sys/random.h malloc.h sched.h sys/statvfs.h sys/resource.h])
-+AC_CHECK_HEADERS([fallocate.h dlfcn.h unistd.h sys/xattr.h attr/xattr.h sys/acl.h sys/ioctl.h sys/reg.h endian.h linux/fs.h linux/fiemap.h stdint.h lzo/lzo1x.h openssl/evp.h linux/random.h sys/random.h malloc.h sched.h sys/statvfs.h sys/resource.h])
- AC_CHECK_FUNCS([ffs ffsl basename fallocate64 splice getopt_long open64 pread pread64 lseek64 stat64 posix_fadvise posix_fadvise64 __builtin_prefetch htobe64 feof_unlocked getline getentropy getrandom posix_memalign valloc sched_yield fstatvfs __builtin_cpu_supports getrlimit aligned_alloc])
- AC_CHECK_LIB(dl,dlsym)
- AC_CHECK_LIB(fallocate,linux_fallocate64)
---
-2.31.1
-