summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/shake
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/shake')
-rw-r--r--sys-fs/shake/Manifest1
-rw-r--r--sys-fs/shake/files/shake-0.999-fix_stat_include.patch22
-rw-r--r--sys-fs/shake/files/shake-0.999-uclibc.patch49
-rw-r--r--sys-fs/shake/metadata.xml9
-rw-r--r--sys-fs/shake/shake-0.999.ebuild26
5 files changed, 107 insertions, 0 deletions
diff --git a/sys-fs/shake/Manifest b/sys-fs/shake/Manifest
new file mode 100644
index 000000000000..29dce23f682f
--- /dev/null
+++ b/sys-fs/shake/Manifest
@@ -0,0 +1 @@
+DIST shake-0.999.tar.bz2 37225 SHA256 f030d5ba5d4d2d449249c49b253a71de8c342b9b2f5e1e7d3e7ba5277e3f5e91 SHA512 7dbd61cb35f771ffae6ec90bcdbf0cc467166661a78379191c7cf888d5f32ad27ea56da739f8f39344a209003747de2be1b57f2335ddc5641f55605c15c84b78 WHIRLPOOL 1d7354dac8aa3582048e8f8532ee308a792c041f15dc7b1e9e68b86b7cbfa66a72bbf9bbca481a3ac9738cb505d529eecd9aae135f2a64cfe5570ace59b862d8
diff --git a/sys-fs/shake/files/shake-0.999-fix_stat_include.patch b/sys-fs/shake/files/shake-0.999-fix_stat_include.patch
new file mode 100644
index 000000000000..b55776397288
--- /dev/null
+++ b/sys-fs/shake/files/shake-0.999-fix_stat_include.patch
@@ -0,0 +1,22 @@
+diff -Naur shake-fs-0.999.orig/judge.c shake-fs-0.999/judge.c
+--- shake-fs-0.999.orig/judge.c 2013-01-21 13:21:17.171974754 +0100
++++ shake-fs-0.999/judge.c 2013-01-21 13:21:31.346958593 +0100
+@@ -26,7 +26,6 @@
+ #include <fcntl.h> // open()
+ #include <sys/types.h> // open(), umask()
+ #include <dirent.h> // scandir()
+-#include <sys/stat.h> // stat(), umask()
+ #include <unistd.h> // stat()
+ #include <stdio.h> // printf(), tmpfile()
+ #include <error.h> // error()
+diff -Naur shake-fs-0.999.orig/judge.h shake-fs-0.999/judge.h
+--- shake-fs-0.999.orig/judge.h 2013-01-21 13:21:17.171974754 +0100
++++ shake-fs-0.999/judge.h 2013-01-21 13:21:47.630940034 +0100
+@@ -22,6 +22,7 @@
+ #include <stdbool.h>
+ #include <fcntl.h>
+ #include <time.h>
++#include <sys/stat.h>
+ typedef unsigned int uint;
+ typedef long long int llint;
+
diff --git a/sys-fs/shake/files/shake-0.999-uclibc.patch b/sys-fs/shake/files/shake-0.999-uclibc.patch
new file mode 100644
index 000000000000..2c54df0b552c
--- /dev/null
+++ b/sys-fs/shake/files/shake-0.999-uclibc.patch
@@ -0,0 +1,49 @@
+--- shake-fs-0.999-orig/executive.c
++++ shake-fs-0.999/executive.c
+@@ -214,12 +214,21 @@ release (struct accused *a, struct law *
+ assert (a->fd >= 0);
+ /* Restores mtime */
+ {
++#ifdef __UCLIBC__
++ struct timespec tv[2];
++ tv[0].tv_sec = a->atime;
++ tv[0].tv_nsec = 0;
++ tv[1].tv_sec = a->mtime;
++ tv[1].tv_nsec = 0;
++ futimens (a->fd, tv);
++#else
+ struct timeval tv[2];
+ tv[0].tv_sec = a->atime;
+ tv[0].tv_usec = 0;
+ tv[1].tv_sec = a->mtime;
+ tv[1].tv_usec = 0;
+ futimes (a->fd, tv);
++#endif
+ }
+ if (has_been_unlocked (a, l))
+ error (0, 0, "%s: concurent accesses", a->name);
+--- shake-fs-0.999-orig/linux.h
++++ shake-fs-0.999/linux.h
+@@ -32,7 +32,6 @@
+ /* Called once, perform OS-specific tasks.
+ */
+ int os_specific_setup (const char *tempfile);
+-
+
+
+ /* Get a write lock on the file.
+@@ -54,12 +53,13 @@ int readlock_to_writelock (int fd);
+ /* Return true if fd is locked, else false
+ */
+ bool is_locked (int fd);
+-
+
+
++#ifndef __UCLIBC__
+ /* Declares the glibc function
+ */
+ int futimes (int fd, const struct timeval tv[2]);
++#endif
+
+ /* Set the shake_ptime field and ctime of the file to the actual date.
+ */
diff --git a/sys-fs/shake/metadata.xml b/sys-fs/shake/metadata.xml
new file mode 100644
index 000000000000..b61b80f7ab1c
--- /dev/null
+++ b/sys-fs/shake/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ </maintainer>
+ <longdescription>Shake is a defragmenter that runs in userspace, without
+then need of patching the kernel and while the system is used </longdescription>
+</pkgmetadata>
diff --git a/sys-fs/shake/shake-0.999.ebuild b/sys-fs/shake/shake-0.999.ebuild
new file mode 100644
index 000000000000..b58f1b6cae7c
--- /dev/null
+++ b/sys-fs/shake/shake-0.999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils
+
+DESCRIPTION="defragmenter that runs in userspace while the system is used"
+HOMEPAGE="http://vleu.net/shake/"
+SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="sys-apps/attr"
+DEPEND="${RDEPEND}
+ sys-apps/help2man"
+
+S=${WORKDIR}/${PN}-fs-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix_stat_include.patch
+ "${FILESDIR}"/${P}-uclibc.patch
+ )