summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/simple-mtpfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/simple-mtpfs')
-rw-r--r--sys-fs/simple-mtpfs/Manifest2
-rw-r--r--sys-fs/simple-mtpfs/metadata.xml20
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-0.1.ebuild26
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild31
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild31
5 files changed, 110 insertions, 0 deletions
diff --git a/sys-fs/simple-mtpfs/Manifest b/sys-fs/simple-mtpfs/Manifest
new file mode 100644
index 000000000000..7a5f16ea777d
--- /dev/null
+++ b/sys-fs/simple-mtpfs/Manifest
@@ -0,0 +1,2 @@
+DIST simple-mtpfs-0.1.tar.gz 116145 SHA256 052618c742e7b3faa95e1c84e8b9e1df1517dccb9460f538bb032223243588a1 SHA512 5c4b390c43ede521061c677b496d47376304a4625414853a2183a41cb4a2c67361ecd7e26d0b6197cc78e84d0a9c99ec92e85bd1c179784b5a7c06ae05ede308 WHIRLPOOL 4df83ffc56339df76124e22f93df8fcf188cad30da83f8a9349e5a8ad8ff64010a0d118bcd4a9719ee0e9a5e3cf2fd997af6f3220951792a5e8f00da3d4a0291
+DIST simple-mtpfs-0.2.tar.gz 35003 SHA256 3ce41fb194971041aa6ad15292a6cdad70eb8b5fc3e7a03a638bc3cac0c515ea SHA512 adb844288af214802ab6e0ddf949d2dc97ec03289db4b68c6b08da00534cdd48f621d8a52287b18d7826cabd78ddad2ca7ded6337016432c473e26c4c6f3c9e5 WHIRLPOOL 9b19d026da2786e8bd08b7c2ea4372cca6bb36e346e0430233af516db50c6d72cef88d65c5da92333941e353534fd486b932573602ea540bd0ba51117ea4c94c
diff --git a/sys-fs/simple-mtpfs/metadata.xml b/sys-fs/simple-mtpfs/metadata.xml
new file mode 100644
index 000000000000..4e5e1a98d139
--- /dev/null
+++ b/sys-fs/simple-mtpfs/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sochotnicky@gentoo.org</email>
+ <name>Stanislav Ochotnicky</name>
+ </maintainer>
+ <longdescription lang="en">
+ SIMPLE-MTPFS (Simple Media Transfer Protocol FileSystem) is a file system for
+ Linux (and other operating systems with a FUSE implementation, such as Mac OS X
+ or FreeBSD) capable of operating on files on MTP devices attached via
+ USB to local machine. On the local computer where the SIMPLE-MTPFS is
+ mounted, the implementation makes use of the FUSE (Filesystem in Userspace)
+ kernel module. The practical effect of this is that the end user can seamlessly
+ interact with MTP device files.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">phatina/simple-mtpfs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-0.1.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-0.1.ebuild
new file mode 100644
index 000000000000..0874155d432c
--- /dev/null
+++ b/sys-fs/simple-mtpfs/simple-mtpfs-0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Simple MTP fuse filesystem driver"
+HOMEPAGE="https://github.com/phatina/simple-mtpfs"
+SRC_URI="mirror://github/phatina/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="media-libs/libmtp
+ >=sys-fs/fuse-2.8"
+
+DEPEND="virtual/pkgconfig
+ ${CDEPEND}"
+
+RDEPEND="${CDEPEND}"
+
+AUTOTOOLS_AUTORECONF=1
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild
new file mode 100644
index 000000000000..1f9cb413674f
--- /dev/null
+++ b/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://github.com/phatina/${PN}.git"
+inherit autotools-utils eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
+
+DESCRIPTION="Simple MTP fuse filesystem driver"
+HOMEPAGE="https://github.com/phatina/simple-mtpfs"
+[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/phatina/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libmtp
+ >=sys-fs/fuse-2.8
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+[[ ${PV} == 9999 ]] || S="${WORKDIR}/${PN}-${P}"
+
+AUTOTOOLS_AUTORECONF=1
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild
new file mode 100644
index 000000000000..1f9cb413674f
--- /dev/null
+++ b/sys-fs/simple-mtpfs/simple-mtpfs-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://github.com/phatina/${PN}.git"
+inherit autotools-utils eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
+
+DESCRIPTION="Simple MTP fuse filesystem driver"
+HOMEPAGE="https://github.com/phatina/simple-mtpfs"
+[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/phatina/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libmtp
+ >=sys-fs/fuse-2.8
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+[[ ${PV} == 9999 ]] || S="${WORKDIR}/${PN}-${P}"
+
+AUTOTOOLS_AUTORECONF=1