summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-12-18 11:57:00 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-12-18 12:03:57 -0800
commitc40d3a5fdfabc90e96db6212924f917283b4cf9c (patch)
treee6e54203670694e87c5cb5259c7252eaafba950f /sys-fs
parentdev-libs/libxml2: fix ROOT reference for EAPI 7 (diff)
downloadgentoo-c40d3a5fdfabc90e96db6212924f917283b4cf9c.tar.gz
gentoo-c40d3a5fdfabc90e96db6212924f917283b4cf9c.tar.bz2
gentoo-c40d3a5fdfabc90e96db6212924f917283b4cf9c.zip
sys-fs/zfs-kmod: replace sed with a proper patch in 0.8.6
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs-kmod/files/0.8.6-copy-builtin.patch27
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild7
2 files changed, 30 insertions, 4 deletions
diff --git a/sys-fs/zfs-kmod/files/0.8.6-copy-builtin.patch b/sys-fs/zfs-kmod/files/0.8.6-copy-builtin.patch
new file mode 100644
index 000000000000..2b1ef8582546
--- /dev/null
+++ b/sys-fs/zfs-kmod/files/0.8.6-copy-builtin.patch
@@ -0,0 +1,27 @@
+From 0ce99b43b339226d62362f624d37f80a921eb197 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Fri, 18 Dec 2020 11:35:07 -0800
+Subject: [PATCH] copy-builtin: handle missing .gitignore
+
+acfc4944d0d6db114db9f2bb5401251c5bd767b6 broke copy-builtin in
+release tarballs, because those do not contain .gitignore file.
+Adding -f to rm call will make it return 0 even if file does not exist.
+
+Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
+---
+ copy-builtin | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/copy-builtin b/copy-builtin
+index 84f469fef02..6a6eb1f3695 100755
+--- a/copy-builtin
++++ b/copy-builtin
+@@ -36,7 +36,7 @@ rm -rf "$KERNEL_DIR/include/zfs" "$KERNEL_DIR/fs/zfs"
+ cp --recursive include "$KERNEL_DIR/include/zfs"
+ cp --recursive module "$KERNEL_DIR/fs/zfs"
+ cp zfs_config.h "$KERNEL_DIR/include/zfs/"
+-rm "$KERNEL_DIR/include/zfs/.gitignore"
++rm -f "$KERNEL_DIR/include/zfs/.gitignore"
+
+ for MODULE in "${MODULES[@]}"
+ do
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild
index cc5f18c90673..9067f3662366 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild
@@ -37,6 +37,9 @@ RESTRICT="debug? ( strip ) test"
DOCS=( AUTHORS COPYRIGHT META README.md )
+# https://github.com/openzfs/zfs/pull/11371
+PATCHES=( "${FILESDIR}/${PV}-copy-builtin.patch" )
+
pkg_setup() {
CONFIG_CHECK="
!DEBUG_LOCK_ALLOC
@@ -94,10 +97,6 @@ src_prepare() {
# Set module revision number
sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" META || die "Could not set Gentoo release"
fi
-
- # undo https://github.com/openzfs/zfs/commit/acfc4944d0d6db114db9f2bb5401251c5bd767b6
- # we use release tarballs with no gitignore files already
- sed -i 's:rm "$KERNEL_DIR/include/zfs/.gitignore"::' copy-builtin || die
}
src_configure() {