summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkuzetsa <kuzetsa@gmail.com>2018-05-25 05:08:56 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-25 08:42:53 -0400
commit9ef4349e81a35cb5d61ad3db78bd7c6a8c4e4ff0 (patch)
tree23c080a695fcbc9567d31322a087c4c3416f5c13 /sys-kernel/ck-sources/ck-sources-4.16.11.ebuild
parentsys-kernel/ck-sources: genpatches-4.14-48 (diff)
downloadgentoo-9ef4349e81a35cb5d61ad3db78bd7c6a8c4e4ff0.tar.gz
gentoo-9ef4349e81a35cb5d61ad3db78bd7c6a8c4e4ff0.tar.bz2
gentoo-9ef4349e81a35cb5d61ad3db78bd7c6a8c4e4ff0.zip
sys-kernel/ck-sources: genpatches-4.16-12
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-4.16.11.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.16.11.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-4.16.11.ebuild b/sys-kernel/ck-sources/ck-sources-4.16.11.ebuild
new file mode 100644
index 000000000000..05d896dd38ed
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-4.16.11.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/
+ http://kernel.kolivas.org/"
+
+IUSE="experimental"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="12"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 kernel-2
+detect_version
+detect_arch
+
+DEPEND="deblob? ( ${PYTHON_DEPS} )"
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Con Kolivas' high performance patchset and Gentoo's genpatches for Linux ${K_BRANCH_ID}"
+
+CK_VERSION="1"
+
+CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.xz"
+
+CK_BASE_URL="http://ck.kolivas.org/patches/4.0"
+CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
+CK_URI="${CK_LVER_URL}/${CK_FILE}"
+CK_URI="${CK_LVER_URL}/${CK_FILE}"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${CK_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_setup() {
+ use deblob && python-any-r1_pkg_setup
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+
+#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
+
+ # linux-info eclass cannot handle recursively expanded variables in Makefile #490328
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile" || die
+
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ elog "ck-sources previously enabled CPU optimizations by default."
+ elog "USE=\"experimental\" is now required to enable this patch."
+ elog "this can be set in /etc/portage/package.use (or make.conf)"
+}