summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrits Letteboer <dagraver@gmail.com>2023-11-16 09:11:50 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-11-16 11:03:43 +0200
commit20d9751920698a1e9cd7875019daede03f5234c5 (patch)
tree0bb3c50ef40be38dc8d167fe17483b19b5546bb7 /sys-kernel/pf-sources
parentsys-kernel/pf-sources: add 6.6-pf1 (diff)
downloadgentoo-20d9751920698a1e9cd7875019daede03f5234c5.tar.gz
gentoo-20d9751920698a1e9cd7875019daede03f5234c5.tar.bz2
gentoo-20d9751920698a1e9cd7875019daede03f5234c5.zip
sys-kernel/pf-sources: add 6.6-pf2
Signed-off-by: Frits Letteboer <dagraver@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33547 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-6.6_p2.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index c2578dec31ca..c50d5e9afd46 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -5,3 +5,4 @@ DIST genpatches-6.6-1.extras.tar.xz 3700 BLAKE2B ae850052cea73d318cfde8ea35eb351
DIST linux-6.5-pf5.tar.gz 228002908 BLAKE2B 9a2aae312b54ff78546bc8c5930510bad72a6c856602adc404b8e4c1e59bba22445b263c8480377e17a5f2698c7efc21c75bf1ad06ebdee31a64fe8fdaa46ed9 SHA512 77cfd8f869b4b5da1f6109f16125605875246233880a71b27545a97bd76d42f78c07c419b7526c5313b591a055430fa8b4fd271192a872b944092520222f4a2f
DIST linux-6.5-pf6.tar.gz 227889902 BLAKE2B d45e370b566cc903bf9cc0880e4f50a68ea675073e81d3784c9e173c21939b68a1f5ab2d7e6740da303c98be8f469c10859f0814cf6e32a6b284cab0d96e21b2 SHA512 b9bbc97b865c5086afbcf3ba8532ed2723dbdb069323eb352f8b33dc5c69b75aae88ab7bfa5090c9f9f624eea4ee1287c301132d87e12b56a4ac6ece317ad668
DIST linux-6.6-pf1.tar.gz 229217046 BLAKE2B 9426ebab28f9ee516dcc48ef8343c624960b1de6b6ddd9b00393b2261ee1516d7f4fd126ff87a597fdfee85387811e9da0c57458909ac85a7edc4cb60594e8eb SHA512 54be704ff20b47df3c1d774ed9c997620df46188739c6f72b305a88200901afb0d0d534011ee65c41974d0a5aa91ad318c0c426332e05c70949a06292b17547c
+DIST linux-6.6-pf2.tar.gz 229223034 BLAKE2B 8e089eb63597d9069a3dd9cafe38269a7c49dffb646f39082916ec818bd9754ff691d4c0c60c7f6df5f720dd404007a1d8a7e2931977a4dcd474dfb04c950562 SHA512 49a7bba50ee00008b6441aa0c6e191866bc1beb042c107b950639e48c3a2c345f7704930c14df0e9e3b6ffeb2fbbfb1330a1a5c1e07378232e2cb2160dd4da4d
diff --git a/sys-kernel/pf-sources/pf-sources-6.6_p2.ebuild b/sys-kernel/pf-sources/pf-sources-6.6_p2.ebuild
new file mode 100644
index 000000000000..2ee0009ae2d4
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-6.6_p2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Define what default functions to run.
+ETYPE="sources"
+
+# Use genpatches but don't include the 'experimental' use flag.
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Genpatches version to use. -pf patch set already includes vanilla linux updates. Regularly "1"
+# is the wanted value here, but the genpatches patch set can be bumped if it includes some
+# important fixes. src_prepare() will handle deleting the updated vanilla linux patches.
+# See https://archives.gentoo.org/gentoo-kernel/ (or subscribe to the list) to see all patches.
+K_GENPATCHES_VER="1"
+
+# -pf patch set already sets EXTRAVERSION to kernel Makefile.
+K_NOSETEXTRAVERSION="1"
+
+# pf-sources is not officially supported/covered by the Gentoo security team.
+K_SECURITY_UNSUPPORTED="1"
+
+# Define which parts to use from genpatches - experimental is already included in the -pf patch
+# set.
+K_WANT_GENPATCHES="base extras"
+
+# Major kernel version, e.g. 5.14.
+SHPV="${PV/_p*/}"
+
+# Replace "_p" with "-pf", since using "-pf" is not allowed for an ebuild name by PMS.
+PFPV="${PV/_p/-pf}"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://pfkernel.natalenko.name/
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="https://codeberg.org/pf-kernel/linux/archive/v${PFPV}.tar.gz -> linux-${PFPV}.tar.gz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PFPV}"
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_unpack() {
+ # Since the Codeberg-hosted pf-sources include full kernel sources, we need to manually override
+ # the src_unpack phase because kernel-2_src_unpack() does a lot of unwanted magic here.
+ unpack ${A}
+
+ mv linux linux-${PFPV} || die "Failed to move source directory"
+}
+
+src_prepare() {
+ # When genpatches basic version is bumped, it also includes vanilla linux updates. Those are
+ # already in the -pf patch set, so need to remove the vanilla linux patches to avoid conflicts.
+ if [[ ${K_GENPATCHES_VER} -ne 1 ]]; then
+ find "${WORKDIR}"/ -type f -name '10*linux*patch' -delete ||
+ die "Failed to delete vanilla linux patches in src_prepare."
+ fi
+
+ # kernel-2_src_prepare doesn't apply PATCHES(). Chosen genpatches are also applied here.
+ eapply "${WORKDIR}"/*.patch
+ default
+}
+
+pkg_postinst() {
+ # Fixes "wrongly" detected directory name, bgo#862534.
+ local KV_FULL="${PFPV}"
+ kernel-2_pkg_postinst
+
+ optfeature "userspace KSM helper" sys-process/uksmd
+}
+
+pkg_postrm() {
+ # Same here, bgo#862534.
+ local KV_FULL="${PFPV}"
+ kernel-2_pkg_postrm
+}