summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2017-01-16 15:14:53 +0100
committerMichael Haubenwallner <haubi@gentoo.org>2017-01-16 15:17:11 +0100
commitc8e5a7b3427a5b30841082958e67980e7a3bb01c (patch)
tree766a309e1aad36fa394300f9057b33b625eb7b77 /sys-libs/cygwin-crypt
parentkde-apps/thumbnailers: Set KDE_BLOCK_SLOT4=false (diff)
downloadgentoo-c8e5a7b3427a5b30841082958e67980e7a3bb01c.tar.gz
gentoo-c8e5a7b3427a5b30841082958e67980e7a3bb01c.tar.bz2
gentoo-c8e5a7b3427a5b30841082958e67980e7a3bb01c.zip
sys-libs/cygwin-crypt: initial commit, v1.4
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-libs/cygwin-crypt')
-rw-r--r--sys-libs/cygwin-crypt/Manifest1
-rw-r--r--sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild42
-rw-r--r--sys-libs/cygwin-crypt/metadata.xml13
3 files changed, 56 insertions, 0 deletions
diff --git a/sys-libs/cygwin-crypt/Manifest b/sys-libs/cygwin-crypt/Manifest
new file mode 100644
index 000000000000..e4cf62363ad5
--- /dev/null
+++ b/sys-libs/cygwin-crypt/Manifest
@@ -0,0 +1 @@
+DIST cygwin-crypt-1.4.tar.bz2 4446 SHA256 26767faae5dab6a8e4103df0d41cd2b07cda97c48a31dfab73949b4df198818b SHA512 1ecc4256730f13161a651cfdf71b27c1042e6f56fb859943426c371d4b37b8b2bd6ea768f86e45f7b8cf3478e97ff9578b79e5c37178c8794ff9b87799f2cab3 WHIRLPOOL def38d196a7cdbcc2fcb307b5aaf45e76a703fb4557475f157f00eb63ca693e02f126f101552a424abb3a19bb8e342c777747b443295551fac637716ea5482a3
diff --git a/sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild b/sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild
new file mode 100644
index 000000000000..6148353483b6
--- /dev/null
+++ b/sys-libs/cygwin-crypt/cygwin-crypt-1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Cygwin Encryption/Decryption utility and library"
+HOMEPAGE="https://sourceware.org/cygwin-apps/"
+# Upstream provides the git repo only, so we do:
+# git clone git://cygwin.com/git/cygwin-apps/crypt.git
+# cd crypt
+# git archive -o cygwin-crypt-${PV}.tar --prefix=cygwin-crypt-${PV}/ crypt-${PV}-release
+# bzip2 cygwin-crypt-${PV}.tar
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~x64-cygwin ~x86-cygwin"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+mymake() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ docdir="${EPREFIX}/share/doc/${P}" \
+ "$@"
+}
+
+src_compile() {
+ mymake
+}
+
+src_install() {
+ mymake install DESTDIR="${D}"
+}
diff --git a/sys-libs/cygwin-crypt/metadata.xml b/sys-libs/cygwin-crypt/metadata.xml
new file mode 100644
index 000000000000..f47e1fc13ea3
--- /dev/null
+++ b/sys-libs/cygwin-crypt/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>haubi@gentoo.org</email>
+ <name>Michael Haubenwallner</name>
+ </maintainer>
+ <longdescription lang="en">
+This packages provides a library which exports the functions crypt(3),
+encrypt(3), and setkey(3). The created passwords are 56 bit DES
+encrypted and are 100% identical to those created by the Linux crypt(3).
+ </longdescription>
+</pkgmetadata>