summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/mtdev
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/mtdev')
-rw-r--r--sys-libs/mtdev/Manifest2
-rw-r--r--sys-libs/mtdev/metadata.xml8
-rw-r--r--sys-libs/mtdev/mtdev-1.1.4.ebuild25
-rw-r--r--sys-libs/mtdev/mtdev-1.1.5.ebuild25
4 files changed, 60 insertions, 0 deletions
diff --git a/sys-libs/mtdev/Manifest b/sys-libs/mtdev/Manifest
new file mode 100644
index 000000000000..4a7e086f3336
--- /dev/null
+++ b/sys-libs/mtdev/Manifest
@@ -0,0 +1,2 @@
+DIST mtdev-1.1.4.tar.bz2 273780 SHA256 6b59b055ff22f2b91d4284187c2515826c338b81f6f33bd90f6bedc7c1fb9a38 SHA512 75da652e720cce9efcc23c2b72a0d8050096f054eff1338e02477816e107d469a7f9c5f4973146d38d939c3515ea39e926c70cf8f2ca0372c83c75506c61732b WHIRLPOOL 7cab0a478f342d019aae9103da36c18fdef137463d820f2f688fab18639e89a7f26b721a551b295df811262bd7d2466a9a405513b033c06abb9fd386a045fec3
+DIST mtdev-1.1.5.tar.bz2 274162 SHA256 6677d5708a7948840de734d8b4675d5980d4561171c5a8e89e54adf7a13eba7f SHA512 78477a4af784e3f846df867f1428ffdc458e3ff33d465d45a84247a7e52f0e215cace397d72be64f6e641f07e0b97a930eff0e07fe9507e0138fb028a4037d6d WHIRLPOOL a0231e159b9a88ab2b46e72d64db1cfb9ae3734f8dc014c3be7bcde6e7c20b9587f0e0be83d5d37fddb5a1896f3419b58a80e97ab669993e6c01b2b1a19da1f2
diff --git a/sys-libs/mtdev/metadata.xml b/sys-libs/mtdev/metadata.xml
new file mode 100644
index 000000000000..1e9847021115
--- /dev/null
+++ b/sys-libs/mtdev/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<maintainer>
+ <email>naota@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-libs/mtdev/mtdev-1.1.4.ebuild b/sys-libs/mtdev/mtdev-1.1.4.ebuild
new file mode 100644
index 000000000000..2b05b2dcb18e
--- /dev/null
+++ b/sys-libs/mtdev/mtdev-1.1.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Multitouch Protocol Translation Library"
+HOMEPAGE="http://bitmath.org/code/mtdev/"
+SRC_URI="http://bitmath.org/code/mtdev/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-kernel/linux-headers-2.6.31"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/sys-libs/mtdev/mtdev-1.1.5.ebuild b/sys-libs/mtdev/mtdev-1.1.5.ebuild
new file mode 100644
index 000000000000..ab9e3f74d5b8
--- /dev/null
+++ b/sys-libs/mtdev/mtdev-1.1.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Multitouch Protocol Translation Library"
+HOMEPAGE="http://bitmath.org/code/mtdev/"
+SRC_URI="http://bitmath.org/code/mtdev/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-kernel/linux-headers-2.6.31"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}