summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-21 03:21:52 +0100
committerSam James <sam@gentoo.org>2023-05-21 03:21:52 +0100
commite8a8f34562f4bf9ba7081c535c7f3466ae143d22 (patch)
tree8ffe2379df610566cab862d5c9745972426ddd67 /sys-libs/ncurses
parentsys-devel/gcc: keyword 11.3.1_p20230518 (diff)
downloadgentoo-e8a8f34562f4bf9ba7081c535c7f3466ae143d22.tar.gz
gentoo-e8a8f34562f4bf9ba7081c535c7f3466ae143d22.tar.bz2
gentoo-e8a8f34562f4bf9ba7081c535c7f3466ae143d22.zip
sys-libs/ncurses: build native tools w/ --without-ada
There's no need for it when building the native tools just for tinfo etc for a 'cross' build. This doesn't affect the installed files. Closes: https://bugs.gentoo.org/823776 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/ncurses')
-rw-r--r--sys-libs/ncurses/ncurses-6.4.ebuild2
-rw-r--r--sys-libs/ncurses/ncurses-6.4_p20230401.ebuild2
-rw-r--r--sys-libs/ncurses/ncurses-6.4_p20230424.ebuild2
-rw-r--r--sys-libs/ncurses/ncurses-6.4_p20230506.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/ncurses/ncurses-6.4.ebuild b/sys-libs/ncurses/ncurses-6.4.ebuild
index 26715df453d0..5c0e899fefad 100644
--- a/sys-libs/ncurses/ncurses-6.4.ebuild
+++ b/sys-libs/ncurses/ncurses-6.4.ebuild
@@ -186,7 +186,7 @@ src_configure() {
CXXFLAGS=${BUILD_CXXFLAGS} \
CPPFLAGS=${BUILD_CPPFLAGS} \
LDFLAGS="${BUILD_LDFLAGS} ${lbuildflags}" \
- do_configure cross --without-shared --with-normal --with-progs
+ do_configure cross --without-shared --with-normal --with-progs --without-ada
fi
multilib-minimal_src_configure
}
diff --git a/sys-libs/ncurses/ncurses-6.4_p20230401.ebuild b/sys-libs/ncurses/ncurses-6.4_p20230401.ebuild
index fef75a86ebec..1bf84eb8b711 100644
--- a/sys-libs/ncurses/ncurses-6.4_p20230401.ebuild
+++ b/sys-libs/ncurses/ncurses-6.4_p20230401.ebuild
@@ -193,7 +193,7 @@ src_configure() {
CXXFLAGS=${BUILD_CXXFLAGS} \
CPPFLAGS=${BUILD_CPPFLAGS} \
LDFLAGS="${BUILD_LDFLAGS} ${lbuildflags}" \
- do_configure cross --without-shared --with-normal --with-progs
+ do_configure cross --without-shared --with-normal --with-progs --without-ada
fi
multilib-minimal_src_configure
}
diff --git a/sys-libs/ncurses/ncurses-6.4_p20230424.ebuild b/sys-libs/ncurses/ncurses-6.4_p20230424.ebuild
index a400ea23f18c..d222c10a6475 100644
--- a/sys-libs/ncurses/ncurses-6.4_p20230424.ebuild
+++ b/sys-libs/ncurses/ncurses-6.4_p20230424.ebuild
@@ -198,7 +198,7 @@ src_configure() {
CXXFLAGS=${BUILD_CXXFLAGS} \
CPPFLAGS=${BUILD_CPPFLAGS} \
LDFLAGS="${BUILD_LDFLAGS} ${lbuildflags}" \
- do_configure cross --without-shared --with-normal --with-progs
+ do_configure cross --without-shared --with-normal --with-progs --without-ada
fi
multilib-minimal_src_configure
}
diff --git a/sys-libs/ncurses/ncurses-6.4_p20230506.ebuild b/sys-libs/ncurses/ncurses-6.4_p20230506.ebuild
index b1551515ea6a..2252727d553a 100644
--- a/sys-libs/ncurses/ncurses-6.4_p20230506.ebuild
+++ b/sys-libs/ncurses/ncurses-6.4_p20230506.ebuild
@@ -203,7 +203,7 @@ src_configure() {
CXXFLAGS=${BUILD_CXXFLAGS} \
CPPFLAGS=${BUILD_CPPFLAGS} \
LDFLAGS="${BUILD_LDFLAGS} ${lbuildflags}" \
- do_configure cross --without-shared --with-normal --with-progs
+ do_configure cross --without-shared --with-normal --with-progs --without-ada
fi
multilib-minimal_src_configure
}