summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-13 15:42:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-13 16:13:46 +0200
commit5ef0acd5eec99728706985569d929efac2741f78 (patch)
tree9865becacf4f50dbb7036f4d92b8755ed5b969d5 /sys-libs/tdb
parentsys-libs/tevent: Removed old. (diff)
downloadgentoo-5ef0acd5eec99728706985569d929efac2741f78.tar.gz
gentoo-5ef0acd5eec99728706985569d929efac2741f78.tar.bz2
gentoo-5ef0acd5eec99728706985569d929efac2741f78.zip
sys-libs/tdb: Bump to version 1.3.16
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'sys-libs/tdb')
-rw-r--r--sys-libs/tdb/Manifest1
-rw-r--r--sys-libs/tdb/tdb-1.3.16.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-libs/tdb/Manifest b/sys-libs/tdb/Manifest
index ff2b22dc1001..c3e97896e8f2 100644
--- a/sys-libs/tdb/Manifest
+++ b/sys-libs/tdb/Manifest
@@ -1,4 +1,5 @@
DIST tdb-1.3.13.tar.gz 498002 BLAKE2B bf29b535acf3838942820a7dc841f635c457999d1ab7456bc598d73c79404dea9ab397eec1725d739bdc9b4a46b6b0ad068ad36d0e7247afccb795d410b15b06 SHA512 d12382a2f75e56d62d151df3390b3ae41c7502d67582812ec6da30913b13feb7ee98572ab5ad5b5ed3bceb41666c3154855727cf5ce249ef583c033819c05f0f
DIST tdb-1.3.14.tar.gz 500877 BLAKE2B f372c789184f1dbf0829c2e0b43c868a8a7c253b23a597b7695b07f92c1dfbd6978152e965702b0adab9e0a4b19be75ce120196e601314895a9f0be578f036d6 SHA512 776b736d5c61cb796e19731141a85606cbe90e09943d813e0b7bf45066656d4a92ba449d0116664f65b9d8e5729bde4526170bbb1b7b46fd7a2fac1508f3841b
DIST tdb-1.3.15.tar.gz 502627 BLAKE2B 44352033c421875f02491551dd8b1aa4a821a5e0070d6a32fc4f7a61535c98114325718c673fe163ad692f797aa2e9c26ca27a69a04459ba8340bbd8caacdfc5 SHA512 553246d5e7a7c22ea1b00962ac635d608f6d2344201862e796cad3b1a20610da1f5652ec9dbcb0187867fbd25f36247fcc34e9b4b2c3488c15d7202c9fb13bbb
+DIST tdb-1.3.16.tar.gz 504330 BLAKE2B 686b6b3d026094a0219f2c5d76f7258cf2f96538f614fa9078ca00368ad64c4e93f2e184c98f3d6f480fec909d94105fdf527d96f3b4ea291d81bb63420d2a99 SHA512 7b17852986e48a32f3f8f303dd2a26503a69fcf7849f22f51483334c9abda9f189b521679e51b4ee5a80197a8f304a084dde0f56d92cfe953d3a4ede557526d2
DIST tdb-1.3.8.tar.gz 494106 BLAKE2B 3ac4418b642472859c37c20477ffcc255be6e435b84f59ee634fb5b80caa38aadbcc761fd2daf7c797f9d9a120dcf6e597b31306f8c67d3e890570dd94e4263f SHA512 9a7040206bbaae419a296714fe14fcbd3b67c0cef2b0f33563d52336aac2fe814049f5136a148fb049a273bb36fe81e3d777df58869c93f45d6e42b4adf9970b
diff --git a/sys-libs/tdb/tdb-1.3.16.ebuild b/sys-libs/tdb/tdb-1.3.16.ebuild
new file mode 100644
index 000000000000..aca8bf7fb4f2
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.3.16.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ default
+ python_fix_shebang .
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure \
+ "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}