summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-30 05:18:01 +0100
committerSam James <sam@gentoo.org>2022-09-30 05:18:42 +0100
commit50e00f1d1a63bac35074f077e07639c704bbc955 (patch)
tree14c82c5a772ac7778c2c3fabc576ec7255901d51 /sys-libs/tevent
parentnet-fs/samba: add talloc/tdb/tevent version checker (diff)
downloadgentoo-50e00f1d1a63bac35074f077e07639c704bbc955.tar.gz
gentoo-50e00f1d1a63bac35074f077e07639c704bbc955.tar.bz2
gentoo-50e00f1d1a63bac35074f077e07639c704bbc955.zip
sys-libs/tevent: add talloc version checker
Nabbed Ionen's sed from wine-proton etc. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/tevent-0.13.0.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/sys-libs/tevent/tevent-0.13.0.ebuild b/sys-libs/tevent/tevent-0.13.0.ebuild
index 8c811eb21fd2..e3914a179a2f 100644
--- a/sys-libs/tevent/tevent-0.13.0.ebuild
+++ b/sys-libs/tevent/tevent-0.13.0.ebuild
@@ -19,12 +19,14 @@ IUSE="python test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="test !test? ( test )"
+TALLOC_VERSION="2.3.4"
+
RDEPEND="
dev-libs/libbsd[${MULTILIB_USEDEP}]
- >=sys-libs/talloc-2.3.4[${MULTILIB_USEDEP}]
+ >=sys-libs/talloc-${TALLOC_VERSION}[${MULTILIB_USEDEP}]
python? (
${PYTHON_DEPS}
- sys-libs/talloc[python,${PYTHON_SINGLE_USEDEP}]
+ >=sys-libs/talloc-${TALLOC_VERSION}[python,${PYTHON_SINGLE_USEDEP}]
)
"
DEPEND="
@@ -47,8 +49,20 @@ pkg_setup() {
export PYTHONHASHSEED=1
}
+check_samba_dep_versions() {
+ actual_talloc_version=$(sed -En '/^VERSION =/{s/[^0-9.]//gp}' lib/talloc/wscript || die)
+ if [[ ${actual_talloc_version} != ${TALLOC_VERSION} ]] ; then
+ eerror "Source talloc version: ${TALLOC_VERSION}"
+ eerror "Ebuild talloc version: ${actual_talloc_version}"
+ die "Ebuild needs to fix TALLOC_VERSION!"
+ fi
+}
+
src_prepare() {
default
+
+ check_samba_dep_versions
+
multilib_copy_sources
}