summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 09:34:51 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-01 14:15:53 +0100
commitc70eb1c6cf4af982c4fd6a234f22bcadbd71375b (patch)
treecf5ab65b4445fe433dacd42a13a21a6e296d5925 /sys-libs
parentsys-libs/compiler-rt-sanitizers: Switch live to monorepo (diff)
downloadgentoo-c70eb1c6cf4af982c4fd6a234f22bcadbd71375b.tar.gz
gentoo-c70eb1c6cf4af982c4fd6a234f22bcadbd71375b.tar.bz2
gentoo-c70eb1c6cf4af982c4fd6a234f22bcadbd71375b.zip
sys-libs/compiler-rt: Switch live to monorepo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild9
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild11
2 files changed, 15 insertions, 5 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
index 13a5397acde0..fe9fd52093ac 100644
--- a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
@@ -14,8 +14,8 @@ inherit cmake-utils flag-o-matic git-r3 llvm multiprocessing \
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/compiler-rt.git
- https://github.com/llvm-mirror/compiler-rt.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/compiler-rt
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
@@ -49,6 +49,11 @@ pkg_setup() {
python-any-r1_pkg_setup
}
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' compiler-rt
+}
+
test_compiler() {
$(tc-getCC) ${CFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c - \
<<<'int main() { return 0; }' &>/dev/null
diff --git a/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild
index 88bfd8aa0ad2..898c8d917487 100644
--- a/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild
@@ -14,9 +14,9 @@ inherit cmake-utils flag-o-matic git-r3 llvm multiprocessing \
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/compiler-rt.git
- https://github.com/llvm-mirror/compiler-rt.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/compiler-rt
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
@@ -50,6 +50,11 @@ pkg_setup() {
python-any-r1_pkg_setup
}
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' compiler-rt
+}
+
test_compiler() {
$(tc-getCC) ${CFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c - \
<<<'int main() { return 0; }' &>/dev/null