summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-14 20:57:44 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-07-21 17:04:20 +0200
commit4264b69be5de58092ddc59e0107a3f3cdf9df853 (patch)
tree7cadf5f466eff4495c24bb2bd83cb108e78211c2 /sys-power/sispmctl
parentsys-power/RyzenAdj: add 0.15.0 (diff)
downloadgentoo-4264b69be5de58092ddc59e0107a3f3cdf9df853.tar.gz
gentoo-4264b69be5de58092ddc59e0107a3f3cdf9df853.tar.bz2
gentoo-4264b69be5de58092ddc59e0107a3f3cdf9df853.zip
sys-power/sispmctl: add 4.12
Closes: https://bugs.gentoo.org/852290 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-power/sispmctl')
-rw-r--r--sys-power/sispmctl/Manifest1
-rw-r--r--sys-power/sispmctl/sispmctl-4.12.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sys-power/sispmctl/Manifest b/sys-power/sispmctl/Manifest
index edc1c177af9d..2111397e0793 100644
--- a/sys-power/sispmctl/Manifest
+++ b/sys-power/sispmctl/Manifest
@@ -1 +1,2 @@
DIST sispmctl-4.1.tar.gz 429477 BLAKE2B fe9231a5a0b22456d81166ae5dbaf98c86a636e79ff09112438c769daa503996128d31609bd90f66a5414459c9fce66956b1ee001ac3d57f8f472a09b34aee20 SHA512 52cf6e7d4df76c1d28d196a81a06dec59047f2d43571bc72ff08a22359c3e5d7a36fd446118036fe35f9c26e59a07563ac15d9e05285e7b09214b68aab5ef488
+DIST sispmctl-4.12.tar.gz 462829 BLAKE2B dccf61386ad337739825c7f885bef0cbf76868f938a2a7e0ea9853c0bd5591a289d82876f800f2839e6cd9be7040dec2c650ea347e446e15ba43f1169c05cd36 SHA512 945dd7a14f1d6c60cf6f9855782608187c94edce2c3acb9c1dabf92022632051bdf659c49d1d82fd8d38283d710a6847ac985e2efca9a157425fdc55545d5a1a
diff --git a/sys-power/sispmctl/sispmctl-4.12.ebuild b/sys-power/sispmctl/sispmctl-4.12.ebuild
new file mode 100644
index 000000000000..800da41c65b6
--- /dev/null
+++ b/sys-power/sispmctl/sispmctl-4.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd udev
+
+DESCRIPTION="GEMBIRD SiS-PM control utility"
+HOMEPAGE="http://sispmctl.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/sispmctl/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ virtual/libusb:0
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/sispmctl
+"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --enable-webless
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ # install udev rules which make the device files writable
+ # by the members of the group sispmctl
+ udev_dorules examples/60-sispmctl.rules
+
+ systemd_dounit examples/${PN}.service
+}
+
+pkg_postinst() {
+ udev_reload
+ einfo "Add users who may run ${PN} to the group '${PN}'"
+}
+
+pkg_postrm() {
+ udev_reload
+}