summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-09-23 21:13:11 +0800
committerYixun Lan <dlan@gentoo.org>2022-09-23 21:13:56 +0800
commit29e6cf72101e6b8e4c4cf3731f196044002ac37b (patch)
tree860558093e8cdc6263b414ce03b4c395abf2e821 /sys-power/thermald
parentdev-util/kernelshark: add myself as a maintainer (diff)
downloadgentoo-29e6cf72101e6b8e4c4cf3731f196044002ac37b.tar.gz
gentoo-29e6cf72101e6b8e4c4cf3731f196044002ac37b.tar.bz2
gentoo-29e6cf72101e6b8e4c4cf3731f196044002ac37b.zip
sys-power/thermald: add 2.5.1
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power/thermald')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.5.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index b26f4898d31a..b57bee2aa716 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,2 +1,3 @@
DIST thermald-2.4.9.tar.gz 144780 BLAKE2B 92eb36c19608c454336d8cf709a1650d5853ca3884c0a99d2371ee5e5d749e1b9cc10eab9a9382e2c43dd7d424d58263de9333aa223902714f8794545a0034bd SHA512 801508cf1d6215fdb40730418d2302469ad88fe4456d6f3f99e8695286b86b5b9ee6c90184cff4ff843e0811451cf96afe15478002cba0b25cda4fe8bdb17de5
+DIST thermald-2.5.1.tar.gz 160908 BLAKE2B 546d540b53365f9f57059dd74378226ba111abdd0bf9a47a2b81b29726cf2b2d99bfdf166f6b50f30071d28c6fad00d84f48e83f886ec8e50f9f08989b28192a SHA512 76974458b3986cb156ee599e9a96be0082f1e4d85cfe40fd387d69992b0b778186b98abb833a0493db9c070feee8c1147dcf591a7aba039c428e925c66bb0e4f
DIST thermald-2.5.tar.gz 160338 BLAKE2B df7004cdd9f0a36479f7d8c129338ac9b2fd3b4deca188ef3568336c448f563460ca74203384694f37a29fd7ba71b52d356f861d28313e52b443a81557ea406e SHA512 0112d1648c6eed127c83eecb69ac5dcd56614dc485a9d54cd14d6506ad1c48c80880b1d3498258d65a0435220ef3ad3f7ddaa1f5a6f9595c9b56e14d71629390
diff --git a/sys-power/thermald/thermald-2.5.1.ebuild b/sys-power/thermald/thermald-2.5.1.ebuild
new file mode 100644
index 000000000000..0bee30caf643
--- /dev/null
+++ b/sys-power/thermald/thermald-2.5.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ sed -i -e "/group=/s/power/wheel/g" \
+ data/org.freedesktop.thermald.conf || die
+
+ sed -i -e '/tdrundir/s@\$localstatedir/run@\$runstatedir@' \
+ configure.ac || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --runstatedir="${EPREFIX}"/run \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}