summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-07-29 13:39:06 -0400
committerBrian Evans <grknight@gentoo.org>2019-07-29 13:39:06 -0400
commit32c593b65a28b6241410bf4e692d97c6fc863ab0 (patch)
tree4253bbb5f8790147e792334158f61520fe67e879 /sys-power
parentwww-client/chromium: fix building on arm64 (diff)
downloadgentoo-32c593b65a28b6241410bf4e692d97c6fc863ab0.tar.gz
gentoo-32c593b65a28b6241410bf4e692d97c6fc863ab0.tar.bz2
gentoo-32c593b65a28b6241410bf4e692d97c6fc863ab0.zip
sys-power/acpilight: Version bump for 1.2
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpilight/Manifest1
-rw-r--r--sys-power/acpilight/acpilight-1.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-power/acpilight/Manifest b/sys-power/acpilight/Manifest
index 334b8c9f546d..0dbc5aab9940 100644
--- a/sys-power/acpilight/Manifest
+++ b/sys-power/acpilight/Manifest
@@ -1,2 +1,3 @@
DIST acpilight-1.0.tar.gz 16452 BLAKE2B 6594612a25974d33d845b9b0dec4ad0a105ea7da0b24dd540385d5a3751058d9b23afe58600082095c041c86cb477f671fcf4bc7f760869f7290e9e62c8c3124 SHA512 f7913f7ebf6cbde95a42165d8bfa237be03d90fc097164b971c92721cc76f1260a6a607d85f3ecb05ec482019f0ed7f0827a473608daf39b0d05b37c1d228a8a
DIST acpilight-v1.1.tar.gz 17583 BLAKE2B 9505d0b2e1eb6e311b3be7938c455dcca399b2a644856f57593be4da56b637445b796f16300540436645b4dc660f7330b63ff3eecf93ecb49b366d152d5c5faf SHA512 af10a538fec83315aaec3837647622ecea41cb936d38667e4e70689a2b8a968a786fc9ad2be136d5799fa091f07614886decc9044e71aec1e64765e90ddae439
+DIST acpilight-v1.2.tar.gz 18068 BLAKE2B 469fd12c0a24b152681d73add559733a294f8a0848f46d0d3a1e209dea2ad3b180294677a8d84a82387ec34b00bbfda85a10f447fe22b81a3c51225cdce14051 SHA512 ef634ec0f315fe94dca138f1b9231f320b93340db3365ab9a09cf898fe4691f70573041bcb04563d760f1201000ea3ff11ab5dad3bfffddf3d3070dedb5732d7
diff --git a/sys-power/acpilight/acpilight-1.2.ebuild b/sys-power/acpilight/acpilight-1.2.ebuild
new file mode 100644
index 000000000000..6bd7e47a9b63
--- /dev/null
+++ b/sys-power/acpilight/acpilight-1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_5 python3_6 python3_7 )
+
+inherit python-r1 udev
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="Replacement for xbacklight that uses the ACPI interface to set brightness"
+HOMEPAGE="https://gitlab.com/wavexx/acpilight/"
+SRC_URI="https://gitlab.com/wavexx/acpilight/-/archive/v${PV}/${MY_P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="virtual/udev
+ acct-group/video
+ ${PYTHON_DEPS}
+ !x11-apps/xbacklight"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DOCS=( README.rst NEWS.rst )
+
+# Disable Makefile that installs by default
+src_compile() { :; }
+
+src_install() {
+ python_foreach_impl python_doscript xbacklight
+ udev_dorules "${S}"/90-backlight.rules
+ doman xbacklight.1
+ einstalldocs
+ newinitd "${FILESDIR}"/acpilight.initd acpilight
+ newconfd "${FILESDIR}"/acpilight.confd acpilight
+}
+
+pkg_postinst() {
+ udev_reload
+ einfo
+ elog "To use the xbacklight binary as a regular user, you must be a part of the video group"
+ einfo
+ elog "If this utility does not find any backlights to manipulate,"
+ elog "verify you have kernel support on the device and display driver enabled."
+ einfo
+ elog "To take advantage of the OpenRC init script, and automate the process of"
+ elog "saving and restoring the brightness level you should add acpilight"
+ elog "to the boot runlevel. You can do this as root like so:"
+ elog "# rc-update add acpilight boot"
+ einfo
+}