summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-10 03:26:12 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-10 03:59:46 -0400
commit53d6602802df3a14d37b3ece87348de708e3e4a2 (patch)
tree3e0d47db0923228a91ad2d747975145f073aca56 /sys-process
parentanacron: use elog instead of einfo for messages #370199 (diff)
downloadgentoo-53d6602802df3a14d37b3ece87348de708e3e4a2.tar.gz
gentoo-53d6602802df3a14d37b3ece87348de708e3e4a2.tar.bz2
gentoo-53d6602802df3a14d37b3ece87348de708e3e4a2.zip
anacron: EAPI: update to 5
This allows us to show the elog messages only once on initial install.
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/anacron/anacron-2.3-r3.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/sys-process/anacron/anacron-2.3-r3.ebuild b/sys-process/anacron/anacron-2.3-r3.ebuild
index 22fd43f6b8dd..d68bb7913a6e 100644
--- a/sys-process/anacron/anacron-2.3-r3.ebuild
+++ b/sys-process/anacron/anacron-2.3-r3.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI="5"
+
inherit eutils
DESCRIPTION="a periodic command scheduler"
@@ -17,17 +19,11 @@ DEPEND="sys-process/cronbase"
RDEPEND="${RDEPEND}
virtual/mta"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-compile-fix-from-debian.patch
sed -i "s:^CFLAGS =:CFLAGS = $CFLAGS:" Makefile
}
-src_compile() {
- emake || die
-}
-
src_install() {
#this does not work if the directory exists already
diropts -m0750 -o root -g cron
@@ -47,14 +43,16 @@ src_install() {
}
pkg_postinst() {
- elog "Schedule the command \"anacron -s\" as a daily cron-job (preferably"
- elog "at some early morning hour). This will make sure that jobs are run"
- elog "when the systems is left running for a night."
- echo
- elog "Update /etc/anacrontab to include what you want anacron to run."
-
- echo
- elog "You may wish to read the Gentoo Linux Cron Guide, which can be"
- elog "found online at:"
- elog " http://www.gentoo.org/doc/en/cron-guide.xml"
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Schedule the command \"anacron -s\" as a daily cron-job (preferably"
+ elog "at some early morning hour). This will make sure that jobs are run"
+ elog "when the systems is left running for a night."
+ echo
+ elog "Update /etc/anacrontab to include what you want anacron to run."
+
+ echo
+ elog "You may wish to read the Gentoo Linux Cron Guide, which can be"
+ elog "found online at:"
+ elog " http://www.gentoo.org/doc/en/cron-guide.xml"
+ fi
}