summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-10-21 13:28:02 +0200
committerFabian Groffen <grobian@gentoo.org>2021-10-21 13:28:08 +0200
commitb60423c2b342a6f797bdd1a8d090704f0295b48e (patch)
treee50d981eaca4fe4d73426ff51fd2467127992b8f /sys-process
parentsys-libs/csu: drop csu-79 (diff)
downloadgentoo-b60423c2b342a6f797bdd1a8d090704f0295b48e.tar.gz
gentoo-b60423c2b342a6f797bdd1a8d090704f0295b48e.tar.bz2
gentoo-b60423c2b342a6f797bdd1a8d090704f0295b48e.zip
sys-process/top-apple: port to EAPI=8, bug #819180
Closes: https://bugs.gentoo.org/819180 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/top-apple/top-apple-73.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-process/top-apple/top-apple-73.ebuild b/sys-process/top-apple/top-apple-73.ebuild
index ddaa676b5d88..be0e8c1b0cec 100644
--- a/sys-process/top-apple/top-apple-73.ebuild
+++ b/sys-process/top-apple/top-apple-73.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit toolchain-funcs epatch
+inherit toolchain-funcs
DESCRIPTION="Apple's top from Mac OS X Lion 10.7"
HOMEPAGE="http://www.opensource.apple.com/"
@@ -21,9 +21,11 @@ S=${WORKDIR}/top-${PV}
src_prepare() {
# libutil.h header is missing at least on Leopard (10.5), the dylib just
# exists
- [[ ! -e ${ROOT}/usr/include/libutil.h ]] && \
+ [[ ! -e ${ESYSROOT}/usr/include/libutil.h ]] && \
cp "${DISTDIR}"/libutil-11-top-${PV}.h "${S}"/libutil.h || die
- epatch "${FILESDIR}"/${P}-darwin9.patch
+ eapply -p0 "${FILESDIR}"/${P}-darwin9.patch
+
+ eapply_user
}
src_compile() {