summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/anyterm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/anyterm')
-rw-r--r--www-apache/anyterm/Manifest1
-rw-r--r--www-apache/anyterm/anyterm-1.1.29.ebuild46
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.28-respect-LDFLAGS.patch26
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch58
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch10
-rw-r--r--www-apache/anyterm/files/anyterm.conf.d7
-rw-r--r--www-apache/anyterm/files/anyterm.init.d21
-rw-r--r--www-apache/anyterm/metadata.xml5
8 files changed, 174 insertions, 0 deletions
diff --git a/www-apache/anyterm/Manifest b/www-apache/anyterm/Manifest
new file mode 100644
index 000000000000..3f6b4f5770e4
--- /dev/null
+++ b/www-apache/anyterm/Manifest
@@ -0,0 +1 @@
+DIST anyterm-1.1.29.tbz2 178424 SHA256 6e7710cf2240cb4eced295bdf17de4b6ce223c7fe4d1668260a6d60a8aec9846
diff --git a/www-apache/anyterm/anyterm-1.1.29.ebuild b/www-apache/anyterm/anyterm-1.1.29.ebuild
new file mode 100644
index 000000000000..98decc427ad5
--- /dev/null
+++ b/www-apache/anyterm/anyterm-1.1.29.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A terminal anywhere"
+HOMEPAGE="http://anyterm.org/"
+SRC_URI="http://anyterm.org/download/${P}.tbz2"
+
+LICENSE="GPL-2 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/ssh"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.34.1"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.1.28-respect-LDFLAGS.patch"
+ epatch "${FILESDIR}/${P}-gcc-4.4.patch"
+ epatch "${FILESDIR}/${P}-boost-1.50.patch"
+}
+
+src_compile() {
+ # this package uses `ld -r -b binary` and thus resulting executable contains
+ # executable stack
+ append-ldflags -Wl,-z,noexecstack
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
+}
+
+src_install() {
+ dosbin anytermd || die
+ dodoc CHANGELOG README || die
+ doman anytermd.1 || die
+ newinitd "${FILESDIR}/anyterm.init.d" anyterm || die
+ newconfd "${FILESDIR}/anyterm.conf.d" anyterm || die
+}
+
+pkg_postinst() {
+ elog "To proceed installation, read following:"
+ elog "http://anyterm.org/1.1/install.html"
+}
diff --git a/www-apache/anyterm/files/anyterm-1.1.28-respect-LDFLAGS.patch b/www-apache/anyterm/files/anyterm-1.1.28-respect-LDFLAGS.patch
new file mode 100644
index 000000000000..25a12e756ab0
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.28-respect-LDFLAGS.patch
@@ -0,0 +1,26 @@
+=== modified file 'common.mk'
+--- common.mk 2009-01-24 12:40:55 +0000
++++ common.mk 2009-01-24 14:02:19 +0000
+@@ -71,7 +71,7 @@
+ OBJS=$(addsuffix .o,$(notdir $(basename $(CC_SRCS))))
+
+ %.o: %.cc
+- $(CXX) $(CC_COMPILE_FLAGS) -c $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(CC_COMPILE_FLAGS) -c $<
+
+ ifdef HAVE_GNU_LD
+ %.blob.o: ../browser/%
+@@ -87,10 +87,10 @@
+
+
+ anytermd: $(OBJS) $(BLOBS) $(LIBPBE_LIB)
+- $(CXX) -o $@ $(OBJS) $(BLOBS) $(LINK_FLAGS)
++ $(CXX) -o $@ $(LDFLAGS) $(OBJS) $(BLOBS) $(LINK_FLAGS)
+
+ %.d: %.cc
+- $(CXX) -MM -MG -MT $@ -MT $(<:%.cc=%.o) $(CPP_FLAGS) $(GCC_FLAGS) -o $@ $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -MM -MG -MT $@ -MT $(<:%.cc=%.o) $(CPP_FLAGS) $(GCC_FLAGS) -o $@ $<
+
+ DEPENDS=$(addsuffix .d,$(basename $(OBJS)))
+
+
diff --git a/www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch b/www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch
new file mode 100644
index 000000000000..b0648a9e3067
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch
@@ -0,0 +1,58 @@
+Patch by Arfrever; sent to upstream developer.
+
+--- libpbe/src/parse_http_request.cc
++++ libpbe/src/parse_http_request.cc
+@@ -18,11 +18,11 @@
+
+ #include "parse_http_request.hh"
+
+-#include <boost/spirit.hpp>
+-#include <boost/spirit/actor/insert_at_actor.hpp>
+-#include <boost/spirit/dynamic/if.hpp>
+-#include <boost/spirit/utility/loops.hpp>
+-#include <boost/spirit/iterator/multi_pass.hpp>
++#include <boost/spirit/include/classic.hpp>
++#include <boost/spirit/include/classic_if.hpp>
++#include <boost/spirit/include/classic_insert_at_actor.hpp>
++#include <boost/spirit/include/classic_loops.hpp>
++#include <boost/spirit/include/classic_multi_pass.hpp>
+
+ #include <boost/lexical_cast.hpp>
+ #include <boost/scoped_array.hpp>
+@@ -31,7 +31,7 @@
+
+
+ using namespace std;
+-using namespace boost::spirit;
++using namespace boost::spirit::classic;
+
+
+ namespace pbe {
+--- libpbe/src/URI.cc
++++ libpbe/src/URI.cc
+@@ -18,11 +18,11 @@
+
+ #include "URI.hh"
+
+-#include <boost/spirit.hpp>
+-#include <boost/spirit/actor/insert_at_actor.hpp>
+-#include <boost/spirit/dynamic/if.hpp>
+-#include <boost/spirit/utility/loops.hpp>
+-#include <boost/spirit/iterator/multi_pass.hpp>
++#include <boost/spirit/include/classic.hpp>
++#include <boost/spirit/include/classic_if.hpp>
++#include <boost/spirit/include/classic_insert_at_actor.hpp>
++#include <boost/spirit/include/classic_loops.hpp>
++#include <boost/spirit/include/classic_multi_pass.hpp>
+
+ #include <boost/lexical_cast.hpp>
+ #include <boost/scoped_array.hpp>
+@@ -30,7 +30,7 @@
+ #include <map>
+
+ using namespace std;
+-using namespace boost::spirit;
++using namespace boost::spirit::classic;
+
+
+ namespace pbe {
diff --git a/www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch b/www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch
new file mode 100644
index 000000000000..3809f5aac186
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch
@@ -0,0 +1,10 @@
+--- libpbe/src/SmtpClient.cc
++++ libpbe/src/SmtpClient.cc
+@@ -20,6 +20,7 @@
+ #include "ip.hh"
+ #include "select.hh"
+
++#include <stdio.h>
+ #include <syslog.h>
+ #include <unistd.h>
+
diff --git a/www-apache/anyterm/files/anyterm.conf.d b/www-apache/anyterm/files/anyterm.conf.d
new file mode 100644
index 000000000000..d4aa00bf987b
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm.conf.d
@@ -0,0 +1,7 @@
+# run anytermd as this user
+USER='nobody'
+# run anyterm on this port
+PORT='7676'
+
+# Other options you wish to pass to anyterm
+ANYTERM_OPTIONS="--local-only"
diff --git a/www-apache/anyterm/files/anyterm.init.d b/www-apache/anyterm/files/anyterm.init.d
new file mode 100644
index 000000000000..771f4bc1c050
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm.init.d
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec /usr/sbin/anytermd -- \
+ --user "${USER}" --port ${PORT} ${ANYTERM_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --exec /usr/sbin/anytermd
+ eend $?
+}
diff --git a/www-apache/anyterm/metadata.xml b/www-apache/anyterm/metadata.xml
new file mode 100644
index 000000000000..6632069b5aff
--- /dev/null
+++ b/www-apache/anyterm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+</pkgmetadata>