summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-04-26 16:40:40 +0000
committerPetr Vaněk <arkamar@gentoo.org>2024-04-27 15:20:50 +0200
commit36aceb163fb98c95f7963a6b8781aeaa0e6fbc2e (patch)
treec1a141c1e5a8dd5810b8fbcbf55ea823ebd9ebe1 /www-apache
parentdev-db/mysql-connector-c++: drop 8.0.31, 8.0.32, 8.0.33 (diff)
downloadgentoo-36aceb163fb98c95f7963a6b8781aeaa0e6fbc2e.tar.gz
gentoo-36aceb163fb98c95f7963a6b8781aeaa0e6fbc2e.tar.bz2
gentoo-36aceb163fb98c95f7963a6b8781aeaa0e6fbc2e.zip
www-apache/modsecurity-crs: add 4.2.0
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/modsecurity-crs/Manifest1
-rw-r--r--www-apache/modsecurity-crs/modsecurity-crs-4.2.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/www-apache/modsecurity-crs/Manifest b/www-apache/modsecurity-crs/Manifest
index 42d6a88cdcda..d81fff64bbcc 100644
--- a/www-apache/modsecurity-crs/Manifest
+++ b/www-apache/modsecurity-crs/Manifest
@@ -1,3 +1,4 @@
DIST modsecurity-crs-3.3.5.tar.gz 299458 BLAKE2B b8617de77cf5168c7b95fab46eae45e2101b4ec7a537d8d471b9b1b27a856b1d370a9de43ee262c07dc9371b3ff79cd86b7328b171fde003da9110897206e91e SHA512 001f9afe25f479dd988aaec1a4a2c0197b2d27e00d2cd10b70892e4889b399259cd0655f42a96965ae655855abdb7f9d8295c225ae17bf1e47361b70232633e5
DIST modsecurity-crs-4.0.0.tar.gz 504720 BLAKE2B e6da0268ae9209179d1f6cefba34e097b614dd4659a4b4df2ef3e6a0b32be7be9d825beaf6d8ca1fbef0dd27217b4707090844e59eaa817111be4a6f8333e205 SHA512 c25bfd6de772815977783e78d7afd388d60bbba151762a38c7050fd5ecde6a48baa0a850028a24d42855ae4a788404ad1ee0f7a4ad2d94d53a46e261a00f7224
DIST modsecurity-crs-4.0.0_rc2.tar.gz 491479 BLAKE2B 71a016b7e45a991373357ece9cc7a59afe54daf91ffa826b76fd4a986b6e8989efb54ca3b83fac9307cf6ede1e1f7a78f9534cc5682e63ea3d75b9092c295d30 SHA512 302129aa3c476afd84b41bfdf73afaa1561f300ecad6ea3540d977639dc3c2167169298fbbe453ceb108d10dee3835b2e4f30f0c12cc413d3acd530906123021
+DIST modsecurity-crs-4.2.0.tar.gz 511240 BLAKE2B f33d1a2bfac809e08ce5480af68b2380b19ea33f4d1409dd79d2117e451631df5b73ba2ccbc6eae2757df3b092c9439bfe79b49658d76fda1a1237f204317080 SHA512 041556b2071385c10a4b4a29ad4f926ee86f819f8b9c95f849e76b3d2724d5fc29c21a69f9eba6fd62e7f5709a109a95feca67a19d8c8d1f0410ee2987ac7a6b
diff --git a/www-apache/modsecurity-crs/modsecurity-crs-4.2.0.ebuild b/www-apache/modsecurity-crs/modsecurity-crs-4.2.0.ebuild
new file mode 100644
index 000000000000..1a0a134d3046
--- /dev/null
+++ b/www-apache/modsecurity-crs/modsecurity-crs-4.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="OWASP ModSecurity Core Rule Set"
+HOMEPAGE="https://coreruleset.org/"
+SRC_URI="https://github.com/coreruleset/coreruleset/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/coreruleset-${MY_PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+apache2"
+
+RDEPEND="apache2? ( >=www-apache/mod_security-2.9.6 )"
+
+DOCS=( CHANGES.md CONTRIBUTORS.md crs-setup.conf.example KNOWN_BUGS.md README.md )
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r plugins rules
+
+ einstalldocs
+
+ if use apache2; then
+ # I don't think it's worth pulling in apache-module.eclass just for
+ # this path...
+ insinto /etc/apache2/modules.d
+ doins "${FILESDIR}/80_mod_security-crs.conf"
+ fi
+}
+
+pkg_postinst() {
+ if use apache2; then
+ einfo "The CRS configuration file has been installed to:"
+ einfo " ${ROOT}/etc/apache2/modules.d/80_mod_security-crs.conf"
+ fi
+
+ optfeature "apache-less installations, e.g. nginx" dev-libs/modsecurity
+}