summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-09 07:32:06 +0100
committerSam James <sam@gentoo.org>2023-04-09 07:32:15 +0100
commit4cf080a536a86eaceb17c82433ff4d81e43047ef (patch)
tree468e5135a9ebf4e87102fe8786f4f927abbbd163 /www-apache
parentdev-python/pywlroots: add virtual/python-cffi dep (diff)
downloadgentoo-4cf080a536a86eaceb17c82433ff4d81e43047ef.tar.gz
gentoo-4cf080a536a86eaceb17c82433ff4d81e43047ef.tar.bz2
gentoo-4cf080a536a86eaceb17c82433ff4d81e43047ef.zip
www-apache/mod_wsgi: add 4.9.4
Closes: https://bugs.gentoo.org/897326 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_wsgi/Manifest1
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-4.9.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/Manifest b/www-apache/mod_wsgi/Manifest
index e326936af388..af283a400011 100644
--- a/www-apache/mod_wsgi/Manifest
+++ b/www-apache/mod_wsgi/Manifest
@@ -1 +1,2 @@
DIST mod_wsgi-4.9.0.tar.gz 699891 BLAKE2B 7ee6ffc28e86baf8ee92973479a26964f7c183c2b113b49a48af02c622f8d8f698abffcd4f522a1ecca5b89325f94856cbe89db5a81d2ac2e87438ee90be97b0 SHA512 9dc34d431171321094a9713444895d9754eff4e69ad1e86c8d3cd77bc1ca0a4c10b697e7f8cf14902d6bfaf205c8842e62fa944bb38f66f1c54fd36af95a09d6
+DIST mod_wsgi-4.9.4.tar.gz 706904 BLAKE2B 6473ee5be4f21d7d5806028b22d582e9d2b6f2a28bb0ed2b03a3da799858bdb4ebcfc85eb7850e91ff041d0c0a6cf2a898bffbbe884faa891c4f1f115d043517 SHA512 0898221d95f0ce374cbd34a1849a6e6b5bd7850644d5fe36f558dcc58095cd535c854cb06798482d312485b8d89b8641d91fa26af3d208e10a6073b885af3199
diff --git a/www-apache/mod_wsgi/mod_wsgi-4.9.4.ebuild b/www-apache/mod_wsgi/mod_wsgi-4.9.4.ebuild
new file mode 100644
index 000000000000..bf1903f177a1
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-4.9.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit apache-module python-single-r1
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications"
+HOMEPAGE="https://github.com/GrahamDumpleton/mod_wsgi"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+APACHE2_MOD_FILE="${S}/src/server/.libs/${PN}.so"
+
+DOCFILES="README.rst"
+
+need_apache2
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ # Calling depend.apache_pkg_setup fails because we do not have
+ # "apache2" in IUSE but the function expects this in order to call
+ # _init_apache2_late which sets the APACHE_MODULESDIR variable.
+ _init_apache2
+ _init_apache2_late
+}
+
+src_configure() {
+ econf --with-apxs="${APXS}" --with-python="${PYTHON}"
+}
+
+src_compile() {
+ default
+}