summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-09-19 17:09:12 -0400
committerCraig Andrews <candrews@gentoo.org>2023-09-19 17:09:28 -0400
commite5d96537642a0e4d3be425b578e739287f9b90fe (patch)
tree9571b17e280b45592b173f40f714651fa0053131 /www-apache
parentgnustep-libs/renaissance: EAPI8 bump, fix LICENSE (diff)
downloadgentoo-e5d96537642a0e4d3be425b578e739287f9b90fe.tar.gz
gentoo-e5d96537642a0e4d3be425b578e739287f9b90fe.tar.bz2
gentoo-e5d96537642a0e4d3be425b578e739287f9b90fe.zip
www-apache/mod_h2: add 2.0.24
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.24.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 12aef10e2fab..681e66a1219a 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.23.tar.gz 689545 BLAKE2B 88955a313ce904f6d82424fd83c1b087cc1b1a44a47fb023a3e022e4ac47571e345ff9adc972deb74ad92057becb1e0100ca4bb5002d0e4e7027dbae9616b757 SHA512 83668000a61dc727ee74f17e950effdf3f9af6e2a097dc6e9f96438c6426f7e6dd879751d511ec036d5ee3554f9c486b1eb13b5bec81898cc1797309e3b5ae36
+DIST mod_h2-2.0.24.tar.gz 689555 BLAKE2B 8fa963a96fb29ba257e4fce072bd7d4bf4e46cfe64f066d9d3a9c692d4bc61552fce3340dd89a0547a6e3dd7180051ce5b0334eae763809e99755441f6203e90 SHA512 1f80c2738f84a58eb691d6a51ed63be4a3567d10501e0fd69aca8519ede8e084b85fb2aad678701b65c6422b6216c005ec8a50199f55e35a1c1197f87dfd5862
diff --git a/www-apache/mod_h2/mod_h2-2.0.24.ebuild b/www-apache/mod_h2/mod_h2-2.0.24.ebuild
new file mode 100644
index 000000000000..5ba43634b8e0
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.24.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}