summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-05 10:40:30 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-05-05 20:56:05 +0200
commit6cf30e2b079d041ee791f811d22239eedbd4a1b6 (patch)
tree209a077dcafa41d1c0d0942ad78a9222931d9a2a /www-apps/icingaweb2-module-pnp4nagios
parentsci-libs/idlcoyote: EAPI8 bump (diff)
downloadgentoo-6cf30e2b079d041ee791f811d22239eedbd4a1b6.tar.gz
gentoo-6cf30e2b079d041ee791f811d22239eedbd4a1b6.tar.bz2
gentoo-6cf30e2b079d041ee791f811d22239eedbd4a1b6.zip
www-apps/icingaweb2-module-pnp4nagios: EAPI8 bump, use https
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/36556 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'www-apps/icingaweb2-module-pnp4nagios')
-rw-r--r--www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild28
-rw-r--r--www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild6
2 files changed, 31 insertions, 3 deletions
diff --git a/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..82cd50c21cf1
--- /dev/null
+++ b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
+HOMEPAGE="https://icinga.org/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-pnp.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-pnp"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ >=www-apps/icingaweb2-2.0.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/pnp"
+ doins -r "${S}"/*
+}
diff --git a/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
index aff9792a698b..82cd50c21cf1 100644
--- a/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
+++ b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
-HOMEPAGE="http://www.icinga.org/"
+HOMEPAGE="https://icinga.org/"
if [[ "${PV}" == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-pnp.git"