summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-01-23 08:35:10 -0500
committerCraig Andrews <candrews@gentoo.org>2023-01-23 08:40:36 -0500
commit3fb475cf50c9c1ff696d92d1db7f9d322a62d148 (patch)
tree7a29bd85b651be7f035f1093ec033974cc9319f7 /www-apps
parentwww-apps/readarr: drop 0.1.1.1526 (diff)
downloadgentoo-3fb475cf50c9c1ff696d92d1db7f9d322a62d148.tar.gz
gentoo-3fb475cf50c9c1ff696d92d1db7f9d322a62d148.tar.bz2
gentoo-3fb475cf50c9c1ff696d92d1db7f9d322a62d148.zip
www-apps/radarr: add 4.4.0.6882
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/radarr/Manifest3
-rw-r--r--www-apps/radarr/radarr-4.4.0.6882.ebuild58
2 files changed, 61 insertions, 0 deletions
diff --git a/www-apps/radarr/Manifest b/www-apps/radarr/Manifest
index c9a61a96c394..202ee5433e8c 100644
--- a/www-apps/radarr/Manifest
+++ b/www-apps/radarr/Manifest
@@ -1,3 +1,6 @@
+DIST Radarr.develop.4.4.0.6882.linux-core-arm.tar.gz 93359609 BLAKE2B e88bfeee2be00a1f3914d51b9aa14a6336dec9c2fa5a33d682a837f05601a6ab09889528ec81617efbb4305c655a4e0c31ab5d074be39f68c8ea50fede93d553 SHA512 5457098a601893d99eeb2d437dbfaf8efb7c07301ddd3868f17cbe28e26b8f1b7e8e937e6334917db316fb5fd360ac8d62605a7022e57964963b0c3803fed96e
+DIST Radarr.develop.4.4.0.6882.linux-core-arm64.tar.gz 93012322 BLAKE2B 01386e124080bf4c23f5d224ca94861527820f05db65ba88cf7c057f1744b3755e011ec9ce100795d9dd16dcc3ed283a1e7c1801689f83a77d0cedb2d98cd012 SHA512 37ffd1381a69c11a9998f4ebd015e1fb46bbe2937f102169713555424fd16a58cb5ebef248c709557186f8383d04a5d1d005ca09e5cc52863ab668fad807b782
+DIST Radarr.develop.4.4.0.6882.linux-core-x64.tar.gz 99002469 BLAKE2B 6d5f28d010b5ea85771aff70e19b16a230b7c123cbf9a2ba82bbf474b2b7227aebee9b8f1904065b71bc56507ed5dd962b0f2c4b8262f562619e99f3c6e1feb9 SHA512 83b6f41dda17381702698485fdcad1b079c94460d0b23d183e718ce4285a02c3ebe7266714d04ae4cee7eeaba1348a1d6a8c7b7fd83c6d18da8c4cd6aa0f181f
DIST Radarr.master.4.3.2.6857.linux-core-arm.tar.gz 93330083 BLAKE2B b1e2b1befab8c993e642ead20377e6ad68d4df86bebef0696efe795b379dcc5ef7d49da2d9a4cc21af788278453e94c592136b24d84df69d827ab7db6a51fcd1 SHA512 0aea9d0b00ea3e44c1f1fe6cd4f8fba09c7cb4fe82c9e700934d4c0b1c2825aeb9de727749ac5a9895bcadc3a63172e303c6683335677d561c95049f3feda975
DIST Radarr.master.4.3.2.6857.linux-core-arm64.tar.gz 92956434 BLAKE2B a6bb3e9e8afe6e54c7e04d26e142ad794657b8b5ab7d5c31b7c6e73924ba3265ef8d95e0c8e1741befd76850a8e3941fd2a285f9e302acd519cb15dae1e0d791 SHA512 3fc1c650f7e2c2c19b1993e40b9ce156d408678f287c968a52b91e972b58379064d0c75b3b227e3611f6e778de4f325d0cc0c5b046ee7d14e552c0ccb34962b0
DIST Radarr.master.4.3.2.6857.linux-core-x64.tar.gz 98967825 BLAKE2B d4caf794f80e55354dd5ad5974d5ed0fda2fd8a99acbbd60d0171be4541c5976f2ad1246e65d343e05205c653b45f2a3c845ba50ecebfc3edbf6bf9d4d14f0ea SHA512 7decade84036f3df91fc083f9dfd8e55f7ac29557df9c007b1786cc49b20aa1b2afec17ff70c83385d103f79938c50450aabe313184b47a331a58ac91feb0fe4
diff --git a/www-apps/radarr/radarr-4.4.0.6882.ebuild b/www-apps/radarr/radarr-4.4.0.6882.ebuild
new file mode 100644
index 000000000000..dfd642cc5114
--- /dev/null
+++ b/www-apps/radarr/radarr-4.4.0.6882.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+SRC_URI="
+ amd64? ( https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-core-x64.tar.gz )
+ arm? ( https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-core-arm.tar.gz )
+ arm64? ( https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-core-arm64.tar.gz )
+"
+
+DESCRIPTION="A fork of Sonarr to work with movies a la Couchpotato"
+HOMEPAGE="https://www.radarr.video"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/radarr
+ acct-user/radarr
+ media-video/mediainfo
+ dev-libs/icu
+ dev-util/lttng-ust:0
+ dev-db/sqlite
+ sys-libs/glibc
+"
+
+QA_PREBUILT="*"
+
+S="${WORKDIR}/Radarr"
+
+src_prepare() {
+ default
+
+ # https://github.com/dotnet/runtime/issues/57784
+ rm libcoreclrtraceptprovider.so Radarr.Update/libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+
+ keepdir /var/lib/${PN}
+ fowners -R ${PN}:${PN} /var/lib/${PN}
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ dodir "/opt/${PN}"
+ cp -R "${S}/." "${D}/opt/radarr" || die "Install failed!"
+
+ systemd_dounit "${FILESDIR}/radarr.service"
+ systemd_newunit "${FILESDIR}/radarr.service" "${PN}@.service"
+}