summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-08-30 12:25:38 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-08-30 12:25:38 +0300
commit95ba59c28195d4ebd07c3ffc7668a5be7ceae91a (patch)
tree9896e6928011c823fea3c168993e60080b5c018e /www-apps
parentwww-apps/dokuwiki: add 20240206b (diff)
downloadgentoo-95ba59c28195d4ebd07c3ffc7668a5be7ceae91a.tar.gz
gentoo-95ba59c28195d4ebd07c3ffc7668a5be7ceae91a.tar.bz2
gentoo-95ba59c28195d4ebd07c3ffc7668a5be7ceae91a.zip
www-apps/dokuwiki: drop 20240206a
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/dokuwiki/Manifest1
-rw-r--r--www-apps/dokuwiki/dokuwiki-20240206a.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/www-apps/dokuwiki/Manifest b/www-apps/dokuwiki/Manifest
index b4637d6a5cf9..7414cc22bd7d 100644
--- a/www-apps/dokuwiki/Manifest
+++ b/www-apps/dokuwiki/Manifest
@@ -1,3 +1,2 @@
DIST dokuwiki-2023-04-04a.tgz 4043928 BLAKE2B a18372b04bd10760236ec4f976a87fed800601a541ebb6aaa07b302c8462286da3094aa102194a101c59ceacde99d0c865f938b8eb732cf09e8e7f0b5f40ea8e SHA512 748af27b2d226437f87461522254fca5e65c7572fdc20e75259944b388e3888a85f61120d1c22c671d3a302ac6791e463a0d3418f2fcf23bf046116107b11ab8
-DIST dokuwiki-2024-02-06a.tgz 4201385 BLAKE2B 3e4541f7e13e400e791af57a3caf7274b5ec7f4608396f7ff91c60f2991f7aea0db2b142a7425d1057a9fb2297200b8b85cbe55af592105927f333dfa228ba44 SHA512 280e450f47237f834256a3a6cd81efe74c82b24b06033d09485bba640d4fd5de72d4fa62129323a6a5f37796357cbe8d3dd1f31b658ca85819e4c9fc47665e2c
DIST dokuwiki-2024-02-06b.tgz 4206676 BLAKE2B d9d01723f0dca747fb5d7c99057c22af916879be05f3d7048af37d51552efeae328231dabd321c03ab7dd09474157372ec95846c5d80f9eb111ce3eb67210c42 SHA512 6edaa8baaf5f1c090476e98fff94f14ef71ea1293c8f7e329cee62dacab6e5f49e7fb016e238c96f0e770927c69e7800d98cce2f2a52aa3d1fefd4c869f1bb4a
diff --git a/www-apps/dokuwiki/dokuwiki-20240206a.ebuild b/www-apps/dokuwiki/dokuwiki-20240206a.ebuild
deleted file mode 100644
index 80ace2977efa..000000000000
--- a/www-apps/dokuwiki/dokuwiki-20240206a.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit webapp
-
-# upstream uses dashes in the datestamp
-MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-
-if [[ ${PV} == *rc* ]]; then
- MY_PV="${MY_BASE_PV}${PV:8:4}"
- MY_P="${PN}-rc-${MY_BASE_PV}"
- S="${WORKDIR}/${MY_P}"
- SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-rc.tgz -> ${PN}-${PV}.tgz"
-else
- MY_PV="${MY_BASE_PV}${PV:8:4}"
- SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs"
-HOMEPAGE="https://wiki.dokuwiki.org"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~sparc ~x86"
-IUSE="gd"
-
-RDEPEND="
- >=dev-lang/php-8.0[xml]
- virtual/httpd-php:*
- gd? ( ||
- (
- dev-lang/php[gd]
- media-gfx/imagemagick
- )
- )
-"
-
-need_httpd_cgi
-
-src_prepare() {
- # create initial changes file
- touch data/changes.log
-
- default
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc README
- rm -f README COPYING
-
- docinto scripts
- dodoc bin/*
- rm -rf bin
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- # Copy custom .htaccess that works with both apache 2.2 and 2.4
- for dir in "conf" "data" "inc" "inc/lang"; do
- insinto "${MY_HTDOCSDIR}/${dir}"
- newins "${FILESDIR}/htaccess" ".htaccess"
- done
-
- # Use custom .htaccess.dist that works with both apache 2.2 and 2.4
- insinto "${MY_HTDOCSDIR}/"
- newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
-
- for x in $(find data/ -not -name '.htaccess'); do
- webapp_serverowned "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
- webapp_configfile "${MY_HTDOCSDIR}"/conf
-
- for x in $(find conf/ -not -name 'msg'); do
- webapp_configfile "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-}