summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-06-09 11:48:10 -0400
committerMike Gilbert <floppym@gentoo.org>2023-06-09 11:52:15 -0400
commita36dfdf047683084b60cace46c53030dd8e0d518 (patch)
tree8ccbed112a380c3f45171fc94765bc59ed47594f /www-plugins/chrome-binary-plugins/chrome-binary-plugins-116.0.5817.0_alpha.ebuild
parentwww-client/google-chrome-unstable: automated update (116.0.5817.0) (diff)
downloadgentoo-a36dfdf047683084b60cace46c53030dd8e0d518.tar.gz
gentoo-a36dfdf047683084b60cace46c53030dd8e0d518.tar.bz2
gentoo-a36dfdf047683084b60cace46c53030dd8e0d518.zip
www-plugins/chrome-binary-plugins: automated update (116.0.5817.0_alpha)
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-116.0.5817.0_alpha.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-116.0.5817.0_alpha.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-116.0.5817.0_alpha.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-116.0.5817.0_alpha.ebuild
new file mode 100644
index 000000000000..238a410c5c55
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-116.0.5817.0_alpha.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2012-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+KEYWORDS="-* ~amd64"
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="google-chrome"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ sys-libs/glibc
+"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/chromium-browser"
+ doins -r WidevineCdm
+}