summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@whissi.de>2016-07-20 01:55:30 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-26 11:51:25 +0200
commit3f6a2bd81eb91481c2ccc0914773410e97c02e0d (patch)
tree8ab4baff7018c019bdc9dbbb20089a2adcdd4ab5 /www-servers
parentwww-servers/nginx: HTTPoxy mitigation added (diff)
downloadgentoo-3f6a2bd81eb91481c2ccc0914773410e97c02e0d.tar.gz
gentoo-3f6a2bd81eb91481c2ccc0914773410e97c02e0d.tar.bz2
gentoo-3f6a2bd81eb91481c2ccc0914773410e97c02e0d.zip
www-servers/nginx: Fix user/group configure argument (bug #588000)
Bug: https://bugs.gentoo.org/588000 Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/nginx-1.10.1-r1.ebuild3
-rw-r--r--www-servers/nginx/nginx-1.11.2.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/www-servers/nginx/nginx-1.10.1-r1.ebuild b/www-servers/nginx/nginx-1.10.1-r1.ebuild
index 59122307314d..3c590167d25b 100644
--- a/www-servers/nginx/nginx-1.10.1-r1.ebuild
+++ b/www-servers/nginx/nginx-1.10.1-r1.ebuild
@@ -554,7 +554,8 @@ src_configure() {
tc-export CC
if ! use prefix; then
- myconf+=( --user=${PN}" "--group=${PN} )
+ myconf+=( --user=${PN} )
+ myconf+=( --group=${PN} )
fi
./configure \
diff --git a/www-servers/nginx/nginx-1.11.2.ebuild b/www-servers/nginx/nginx-1.11.2.ebuild
index 0a7e068169ff..471bfe0aff79 100644
--- a/www-servers/nginx/nginx-1.11.2.ebuild
+++ b/www-servers/nginx/nginx-1.11.2.ebuild
@@ -560,7 +560,8 @@ src_configure() {
tc-export CC
if ! use prefix; then
- myconf+=( --user=${PN}" "--group=${PN} )
+ myconf+=( --user=${PN} )
+ myconf+=( --group=${PN} )
fi
./configure \