summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-06-13 15:28:21 -0400
committerMatt Turner <mattst88@gentoo.org>2019-06-13 15:31:26 -0400
commit187b4281a273c9d358a1dbd8927956e7a5ddce23 (patch)
tree9f641d3fad192e8d1757fb7eb2546b82fc483b0d /x11-apps/igt-gpu-tools
parentmedia-fonts/source-pro: arm stable, bug #683252 (diff)
downloadgentoo-187b4281a273c9d358a1dbd8927956e7a5ddce23.tar.gz
gentoo-187b4281a273c9d358a1dbd8927956e7a5ddce23.tar.bz2
gentoo-187b4281a273c9d358a1dbd8927956e7a5ddce23.zip
x11-apps/igt-gpu-tools: Use meson_feature function
Closes: https://bugs.gentoo.org/687880 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps/igt-gpu-tools')
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
index 81fff23b3e74..8662c0102ba5 100644
--- a/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
@@ -88,16 +88,16 @@ src_configure() {
use overlay && use X && overlay_backends+="x,"
local emesonargs=(
- -Dbuild_chamelium=$(usex chamelium true false)
- -Dbuild_docs=$(usex doc true false)
- -Dbuild_man=$(usex man true false)
- -Dbuild_overlay=$(usex overlay true false)
- -Dbuild_runner=$(usex runner true false)
- -Dbuild_tests=$(usex doc true false) # Test build is required for docs
+ $(meson_feature chamelium build_chamelium)
+ $(meson_feature doc build_docs)
+ $(meson_feature man build_man)
+ $(meson_feature overlay build_overlay)
+ $(meson_feature runner build_runner)
+ $(meson_feature doc build_tests) # Test build is required for docs
+ $(meson_feature valgrind with_valgrind)
+ $(meson_feature unwind with_libunwind)
-Doverlay_backends=${overlay_backends%?}
-Dwith_libdrm=${gpus%?}
- -Dwith_libunwind=$(usex unwind true false)
- -Dwith_valgrind=$(usex valgrind true false)
)
meson_src_configure
}