summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-05-27 16:52:33 -0700
committerMatt Turner <mattst88@gentoo.org>2018-05-27 16:57:23 -0700
commit05bdf9a6d350b4cd2a1946051d08b7b68135c0f2 (patch)
tree0dbf45a67f01579e3a8d099bea45fb7d3481009a /x11-drivers/xf86-video-ati
parentsys-kernel/git-sources: Linux patch 4.17-rc7 (diff)
downloadgentoo-05bdf9a6d350b4cd2a1946051d08b7b68135c0f2.tar.gz
gentoo-05bdf9a6d350b4cd2a1946051d08b7b68135c0f2.tar.bz2
gentoo-05bdf9a6d350b4cd2a1946051d08b7b68135c0f2.zip
x11-drivers/xf86-video-ati: Depend on virtual/libudev:=
Bug: https://bugs.gentoo.org/545906
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-18.0.1-r1.ebuild44
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild2
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-18.0.1-r1.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-18.0.1-r1.ebuild
new file mode 100644
index 000000000000..10c93ae64018
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-18.0.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_DRI=always
+inherit linux-info xorg-2
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="https://www.x.org/wiki/ati/"
+
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( x11-base/xorg-server[glamor] )
+ udev? ( virtual/libudev:= )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ xorg-2_src_configure
+}
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
index 3bb9e4ef6269..3f5390aec7a0 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
@@ -20,7 +20,7 @@ IUSE="+glamor udev"
RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_radeon]
>=x11-libs/libpciaccess-0.8.0
glamor? ( x11-base/xorg-server[glamor] )
- udev? ( virtual/udev )"
+ udev? ( virtual/libudev:= )"
DEPEND="${RDEPEND}
x11-base/xorg-proto"