summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/gl2ps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/gl2ps')
-rw-r--r--x11-libs/gl2ps/Manifest3
-rw-r--r--x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch61
-rw-r--r--x11-libs/gl2ps/files/gl2ps-1.3.7-cmake.patch74
-rw-r--r--x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch74
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.6.ebuild48
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.7.ebuild49
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.8.ebuild49
-rw-r--r--x11-libs/gl2ps/metadata.xml14
8 files changed, 372 insertions, 0 deletions
diff --git a/x11-libs/gl2ps/Manifest b/x11-libs/gl2ps/Manifest
new file mode 100644
index 000000000000..4b3aa543bbb8
--- /dev/null
+++ b/x11-libs/gl2ps/Manifest
@@ -0,0 +1,3 @@
+DIST gl2ps-1.3.6.tgz 294517 SHA256 fd78ded7c4a323a23c3e75f160ca2800401b1771fd4183ca52d233cce892d589 SHA512 e86ed6df6a81506baed1afee6ecababa1f5a81187f675f39a91b7e1f34335dc741bd95af8714fb074c8b9a9a615b7e98bfaa1c3b8831518384566593fdd35270 WHIRLPOOL 87cd785e161a46b126b9a61bb56b2fc6cf3b1e47790a0e00d3a59203c4c3bda46917a57f4a9adcdb3c1a157f7388c77acac395a8d98474040a982b7667dea442
+DIST gl2ps-1.3.7.tgz 294704 SHA256 e916a35a8d35a928aa3404377b579054a5775ef1c88f0fcab4e275d6fe774ff5 SHA512 0824e4214c25f97b96f634b3e16b78bdbade42919e5a7aad09c92eae17a24b61416a25606ceaf5224c53e0d7b1190636e4f925e85eff6272381692f9ba9dcc91 WHIRLPOOL e48561330e609679ef11e1ec655c3333f7abe1a408fb8efe32a3c01b14847edfa9078ac63387e47a70381f241a629a9a84433889aaa7a8d8057dd92cf9edbbb6
+DIST gl2ps-1.3.8.tgz 296245 SHA256 2fe58dd95df06688a8c188e70b1803093ebf0797954901f4a36a403dbc301ee5 SHA512 76e90d675764196d249d87c6041088736a8b41d9b93620c6171a40362a259d50e34d5efc06e4ea17e6c147bc26b6a3a7356d95ea5e204193ef631fb48e0c0a4e WHIRLPOOL 85d93e744824f1681f562f791e07411cb5d815575847466a235e9952f2061c970cbf546e0dc6c5ed36f0261943814ce1a978f497f58b29b2a527245ad856b90b
diff --git a/x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch b/x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch
new file mode 100644
index 000000000000..53e0fba7e493
--- /dev/null
+++ b/x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch
@@ -0,0 +1,61 @@
+--- CMakeLists.txt.orig 2011-08-14 18:15:31.000000000 +0100
++++ CMakeLists.txt 2011-11-27 05:25:50.000000000 +0000
+@@ -46,6 +46,7 @@
+
+ option(ENABLE_ZLIB "Enable compression using ZLIB" ON)
+ option(ENABLE_PNG "Enable PNG support" ON)
++option(ENABLE_DOC "Enable documentation" OFF)
+
+ set(GL2PS_MAJOR_VERSION 1)
+ set(GL2PS_MINOR_VERSION 3)
+@@ -103,8 +104,6 @@
+ include_directories(${EXTERNAL_INCLUDES})
+
+ if(OPENGL_FOUND)
+- add_library(lib STATIC gl2ps.c gl2ps.h)
+- set_target_properties(lib PROPERTIES OUTPUT_NAME gl2ps)
+
+ add_library(shared SHARED gl2ps.c gl2ps.h)
+ target_link_libraries(shared ${EXTERNAL_LIBRARIES})
+@@ -116,29 +115,22 @@
+ set_target_properties(shared PROPERTIES COMPILE_FLAGS "-DGL2PSDLL -DGL2PSDLL_EXPORTS")
+ endif(MSVC)
+
+- install(TARGETS lib shared DESTINATION lib)
++ install(TARGETS shared DESTINATION lib${LIB_SUFFIX})
+ endif(OPENGL_FOUND)
+
+ if(WIN32)
+ set(GL2PS_DOC .)
+ else(WIN32)
+- set(GL2PS_DOC share/doc/gl2ps)
++ set(GL2PS_DOC share/doc/gl2ps-${GL2PS_VERSION})
+ endif(WIN32)
+
+ install(FILES gl2ps.h DESTINATION include)
+ install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.LGPL DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.GL2PS DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTest.c DESTINATION ${GL2PS_DOC})
++install(FILES ${CMAKE_SOURCE_DIR}/TODO.txt DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTestSimple.c DESTINATION ${GL2PS_DOC})
+
+-if(GLUT_FOUND)
+- add_executable(gl2psTest WIN32 gl2psTest.c)
+- target_link_libraries(gl2psTest lib ${EXTERNAL_LIBRARIES})
+- add_executable(gl2psTestSimple WIN32 gl2psTestSimple.c)
+- target_link_libraries(gl2psTestSimple lib ${EXTERNAL_LIBRARIES})
+-endif(GLUT_FOUND)
+-
++if(ENABLE_DOC)
+ find_package(LATEX)
+ if(PDFLATEX_COMPILER)
+ add_custom_command(OUTPUT gl2ps.pdf DEPENDS gl2ps.tex
+@@ -157,6 +149,7 @@
+ add_custom_target(html DEPENDS gl2ps.html)
+ endif(TTH)
+ endif(PDFLATEX_COMPILER)
++endif(ENABLE_DOC)
+
+ set(CPACK_PACKAGE_VENDOR "Christophe Geuzaine")
+ set(CPACK_PACKAGE_VERSION_MAJOR ${GL2PS_MAJOR_VERSION})
diff --git a/x11-libs/gl2ps/files/gl2ps-1.3.7-cmake.patch b/x11-libs/gl2ps/files/gl2ps-1.3.7-cmake.patch
new file mode 100644
index 000000000000..5382b5b3ae73
--- /dev/null
+++ b/x11-libs/gl2ps/files/gl2ps-1.3.7-cmake.patch
@@ -0,0 +1,74 @@
+From: Sebastien Fabbro <bicatali@gentoo.org>
+
+Patch to add various enhancements to cmake:
+* use GNU standard CMAKE_INSTALL_DOCDIR
+* optional documenation building
+* optional examples building
+* do not install static libraries
+
+--- CMakeLists.txt 2012-09-02 02:07:33.000000000 -0700
++++ CMakeLists.txt 2012-09-17 13:51:58.337832078 -0700
+@@ -46,6 +46,8 @@
+
+ option(ENABLE_ZLIB "Enable compression using ZLIB" ON)
+ option(ENABLE_PNG "Enable PNG support" ON)
++option(ENABLE_DOC "Enable documentation" OFF)
++option(ENABLE_EXAMPLES "Build and install examples" OFF)
+
+ set(GL2PS_MAJOR_VERSION 1)
+ set(GL2PS_MINOR_VERSION 3)
+@@ -103,8 +105,6 @@
+ include_directories(${EXTERNAL_INCLUDES})
+
+ if(OPENGL_FOUND)
+- add_library(lib STATIC gl2ps.c gl2ps.h)
+- set_target_properties(lib PROPERTIES OUTPUT_NAME gl2ps)
+
+ add_library(shared SHARED gl2ps.c gl2ps.h)
+ target_link_libraries(shared ${EXTERNAL_LIBRARIES})
+@@ -116,29 +116,32 @@
+ set_target_properties(shared PROPERTIES COMPILE_FLAGS "-DGL2PSDLL -DGL2PSDLL_EXPORTS")
+ endif(MSVC)
+
+- install(TARGETS lib shared DESTINATION lib${LIB_SUFFIX})
++ install(TARGETS shared DESTINATION lib${LIB_SUFFIX})
+ endif(OPENGL_FOUND)
+
+ if(WIN32)
+ set(GL2PS_DOC .)
+ else(WIN32)
+- set(GL2PS_DOC share/doc/gl2ps)
++ set(GL2PS_DOC ${CMAKE_INSTALL_DOCDIR})
+ endif(WIN32)
+
+ install(FILES gl2ps.h DESTINATION include)
+ install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.LGPL DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.GL2PS DESTINATION ${GL2PS_DOC})
++install(FILES ${CMAKE_SOURCE_DIR}/TODO.txt DESTINATION ${GL2PS_DOC})
++
++
++if(ENABLE_EXAMPLES)
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTest.c DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTestSimple.c DESTINATION ${GL2PS_DOC})
+-
+ if(GLUT_FOUND)
+ add_executable(gl2psTest WIN32 gl2psTest.c)
+ target_link_libraries(gl2psTest lib ${EXTERNAL_LIBRARIES})
+ add_executable(gl2psTestSimple WIN32 gl2psTestSimple.c)
+ target_link_libraries(gl2psTestSimple lib ${EXTERNAL_LIBRARIES})
+ endif(GLUT_FOUND)
++endif(ENABLE_EXAMPLES)
+
++if(ENABLE_DOC)
+ find_package(LATEX)
+ if(PDFLATEX_COMPILER)
+ add_custom_command(OUTPUT gl2ps.pdf DEPENDS gl2ps.tex
+@@ -157,6 +160,7 @@
+ add_custom_target(html DEPENDS gl2ps.html)
+ endif(TTH)
+ endif(PDFLATEX_COMPILER)
++endif(ENABLE_DOC)
+
+ set(CPACK_PACKAGE_VENDOR "Christophe Geuzaine")
+ set(CPACK_PACKAGE_VERSION_MAJOR ${GL2PS_MAJOR_VERSION})
diff --git a/x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch b/x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch
new file mode 100644
index 000000000000..5382b5b3ae73
--- /dev/null
+++ b/x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch
@@ -0,0 +1,74 @@
+From: Sebastien Fabbro <bicatali@gentoo.org>
+
+Patch to add various enhancements to cmake:
+* use GNU standard CMAKE_INSTALL_DOCDIR
+* optional documenation building
+* optional examples building
+* do not install static libraries
+
+--- CMakeLists.txt 2012-09-02 02:07:33.000000000 -0700
++++ CMakeLists.txt 2012-09-17 13:51:58.337832078 -0700
+@@ -46,6 +46,8 @@
+
+ option(ENABLE_ZLIB "Enable compression using ZLIB" ON)
+ option(ENABLE_PNG "Enable PNG support" ON)
++option(ENABLE_DOC "Enable documentation" OFF)
++option(ENABLE_EXAMPLES "Build and install examples" OFF)
+
+ set(GL2PS_MAJOR_VERSION 1)
+ set(GL2PS_MINOR_VERSION 3)
+@@ -103,8 +105,6 @@
+ include_directories(${EXTERNAL_INCLUDES})
+
+ if(OPENGL_FOUND)
+- add_library(lib STATIC gl2ps.c gl2ps.h)
+- set_target_properties(lib PROPERTIES OUTPUT_NAME gl2ps)
+
+ add_library(shared SHARED gl2ps.c gl2ps.h)
+ target_link_libraries(shared ${EXTERNAL_LIBRARIES})
+@@ -116,29 +116,32 @@
+ set_target_properties(shared PROPERTIES COMPILE_FLAGS "-DGL2PSDLL -DGL2PSDLL_EXPORTS")
+ endif(MSVC)
+
+- install(TARGETS lib shared DESTINATION lib${LIB_SUFFIX})
++ install(TARGETS shared DESTINATION lib${LIB_SUFFIX})
+ endif(OPENGL_FOUND)
+
+ if(WIN32)
+ set(GL2PS_DOC .)
+ else(WIN32)
+- set(GL2PS_DOC share/doc/gl2ps)
++ set(GL2PS_DOC ${CMAKE_INSTALL_DOCDIR})
+ endif(WIN32)
+
+ install(FILES gl2ps.h DESTINATION include)
+ install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.LGPL DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.GL2PS DESTINATION ${GL2PS_DOC})
++install(FILES ${CMAKE_SOURCE_DIR}/TODO.txt DESTINATION ${GL2PS_DOC})
++
++
++if(ENABLE_EXAMPLES)
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTest.c DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTestSimple.c DESTINATION ${GL2PS_DOC})
+-
+ if(GLUT_FOUND)
+ add_executable(gl2psTest WIN32 gl2psTest.c)
+ target_link_libraries(gl2psTest lib ${EXTERNAL_LIBRARIES})
+ add_executable(gl2psTestSimple WIN32 gl2psTestSimple.c)
+ target_link_libraries(gl2psTestSimple lib ${EXTERNAL_LIBRARIES})
+ endif(GLUT_FOUND)
++endif(ENABLE_EXAMPLES)
+
++if(ENABLE_DOC)
+ find_package(LATEX)
+ if(PDFLATEX_COMPILER)
+ add_custom_command(OUTPUT gl2ps.pdf DEPENDS gl2ps.tex
+@@ -157,6 +160,7 @@
+ add_custom_target(html DEPENDS gl2ps.html)
+ endif(TTH)
+ endif(PDFLATEX_COMPILER)
++endif(ENABLE_DOC)
+
+ set(CPACK_PACKAGE_VENDOR "Christophe Geuzaine")
+ set(CPACK_PACKAGE_VERSION_MAJOR ${GL2PS_MAJOR_VERSION})
diff --git a/x11-libs/gl2ps/gl2ps-1.3.6.ebuild b/x11-libs/gl2ps/gl2ps-1.3.6.ebuild
new file mode 100644
index 000000000000..db2d4d1846a7
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.3.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils multilib
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="http://www.geuz.org/gl2ps/"
+SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc png zlib"
+
+DEPEND="
+ media-libs/freeglut
+ x11-libs/libXmu
+ png? ( media-libs/libpng )
+ doc? (
+ dev-tex/tth
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=( "${FILESDIR}"/${P}-CMakeLists.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable png PNG)
+ $(cmake-utils_use_enable zlib ZLIB)
+ $(cmake-utils_use_enable doc DOC)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib \
+ "${D%/}${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib || die
+ fi
+}
diff --git a/x11-libs/gl2ps/gl2ps-1.3.7.ebuild b/x11-libs/gl2ps/gl2ps-1.3.7.ebuild
new file mode 100644
index 000000000000..d5a22fbb457a
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.3.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils multilib
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="http://www.geuz.org/gl2ps/"
+SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc png zlib"
+
+RDEPEND="
+ media-libs/freeglut
+ x11-libs/libXmu
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-tex/tth
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended )"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ $(cmake-utils_use_enable png PNG)
+ $(cmake-utils_use_enable zlib ZLIB)
+ $(cmake-utils_use_enable doc DOC)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib \
+ "${D%/}${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib || die
+ fi
+}
diff --git a/x11-libs/gl2ps/gl2ps-1.3.8.ebuild b/x11-libs/gl2ps/gl2ps-1.3.8.ebuild
new file mode 100644
index 000000000000..0018ecdb1066
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.3.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils multilib
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="http://www.geuz.org/gl2ps/"
+SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc png zlib"
+
+RDEPEND="
+ media-libs/freeglut
+ x11-libs/libXmu
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-tex/tth
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended )"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ $(cmake-utils_use_enable png PNG)
+ $(cmake-utils_use_enable zlib ZLIB)
+ $(cmake-utils_use_enable doc DOC)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib \
+ "${D%/}${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib || die
+ fi
+}
diff --git a/x11-libs/gl2ps/metadata.xml b/x11-libs/gl2ps/metadata.xml
new file mode 100644
index 000000000000..678526ea433f
--- /dev/null
+++ b/x11-libs/gl2ps/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ GL2PS is a C library providing high quality vector output for any
+ OpenGL application. The main difference between GL2PS and other
+ similar libraries is the use of sorting algorithms
+ capable of handling intersecting and stretched polygons, as well as
+ non manifold objects. GL2PS provides advanced smooth shading and
+ text rendering, culling of invisible primitives, mixed vector/bitmap
+ output, and much more.
+</longdescription>
+</pkgmetadata>