summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-10 13:52:31 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-10 13:52:31 +0100
commit377d3d80573bdb60ce7e5aa01809f012ee9e233d (patch)
tree778aa0efbad92fbb225c4b684d7db7a667df46d3 /x11-libs/libGLw
parentapp-text/texlive-core: Drop old (diff)
downloadgentoo-377d3d80573bdb60ce7e5aa01809f012ee9e233d.tar.gz
gentoo-377d3d80573bdb60ce7e5aa01809f012ee9e233d.tar.bz2
gentoo-377d3d80573bdb60ce7e5aa01809f012ee9e233d.zip
x11-libs/libGLw: Fix for -fno-common
Closes: https://bugs.gentoo.org/706600 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-libs/libGLw')
-rw-r--r--x11-libs/libGLw/files/libGLw-8.0.0-gcc10-fno-common.patch20
-rw-r--r--x11-libs/libGLw/libGLw-8.0.0-r1.ebuild (renamed from x11-libs/libGLw/libGLw-8.0.0.ebuild)4
2 files changed, 23 insertions, 1 deletions
diff --git a/x11-libs/libGLw/files/libGLw-8.0.0-gcc10-fno-common.patch b/x11-libs/libGLw/files/libGLw-8.0.0-gcc10-fno-common.patch
new file mode 100644
index 000000000000..ad0253270937
--- /dev/null
+++ b/x11-libs/libGLw/files/libGLw-8.0.0-gcc10-fno-common.patch
@@ -0,0 +1,20 @@
+--- a/GLwDrawA.h
++++ b/GLwDrawA.h
+@@ -136,7 +136,7 @@
+ typedef struct _GLwMDrawingAreaClassRec *GLwMDrawingAreaWidgetClass;
+ typedef struct _GLwMDrawingAreaRec *GLwMDrawingAreaWidget;
+
+-GLAPI WidgetClass glwMDrawingAreaWidgetClass;
++extern GLAPI WidgetClass glwMDrawingAreaWidgetClass;
+
+
+ #else
+@@ -144,7 +144,7 @@
+ typedef struct _GLwDrawingAreaClassRec *GLwDrawingAreaWidgetClass;
+ typedef struct _GLwDrawingAreaRec *GLwDrawingAreaWidget;
+
+-GLAPI WidgetClass glwDrawingAreaWidgetClass;
++extern GLAPI WidgetClass glwDrawingAreaWidgetClass;
+
+
+ #endif
diff --git a/x11-libs/libGLw/libGLw-8.0.0.ebuild b/x11-libs/libGLw/libGLw-8.0.0-r1.ebuild
index 94fc2c6d16f3..202de4da9755 100644
--- a/x11-libs/libGLw/libGLw-8.0.0.ebuild
+++ b/x11-libs/libGLw/libGLw-8.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,8 @@ BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${P}-gcc10-fno-common.patch )
+
src_configure() {
econf \
--disable-static \