summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libyui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libyui')
-rw-r--r--x11-libs/libyui/Manifest1
-rw-r--r--x11-libs/libyui/files/libyui-3.0.13-fix-qt-libs-check.patch34
-rw-r--r--x11-libs/libyui/libyui-3.0.13.ebuild51
-rw-r--r--x11-libs/libyui/metadata.xml14
4 files changed, 100 insertions, 0 deletions
diff --git a/x11-libs/libyui/Manifest b/x11-libs/libyui/Manifest
new file mode 100644
index 000000000000..64dd43bd1736
--- /dev/null
+++ b/x11-libs/libyui/Manifest
@@ -0,0 +1 @@
+DIST libyui-3.0.13.tar.gz 204028 SHA256 aa3d961f4424365efdfffd4de1facdcd870570890681ebc9e59d16ea3687e44f SHA512 b698c4d44d9fa1d888b52f8d5e2216ff4a490ef97c153fac52674a237527807140663d87ceac7b36b0c6092e9035eaec7bfe7a2e1e93922de106873130a69c66 WHIRLPOOL a7c01af68f800e1f27ce5631c0b34ea35d3f82c3d173caea1516887de9bef557662ce0e577daa6ffb2003070adac40f958c7f3dd9c64d32b46fc11d4fed72b15
diff --git a/x11-libs/libyui/files/libyui-3.0.13-fix-qt-libs-check.patch b/x11-libs/libyui/files/libyui-3.0.13-fix-qt-libs-check.patch
new file mode 100644
index 000000000000..63ac43ee1af9
--- /dev/null
+++ b/x11-libs/libyui/files/libyui-3.0.13-fix-qt-libs-check.patch
@@ -0,0 +1,34 @@
+--- buildtools/LibyuiCommon.cmake 2014-02-10 19:41:45.000000000 +0400
++++ buildtools/LibyuiCommon.cmake 2014-09-10 23:16:10.317115440 +0400
+@@ -245,12 +245,17 @@
+
+ MACRO( FIND_LINKER_LIBS ) # try to find all libs to be linked against
+ FOREACH( p ${LIB_LINKER})
+- FIND_LIBRARY( ${p}_LOOKUP "${p}" )
+- IF( "${${p}_LOOKUP}" STREQUAL "${p}_LOOKUP-NOTFOUND" )
+- MESSAGE( FATAL_ERROR "Linker-Library ${p} NOT FOUND" )
+- ELSE( "${${p}_LOOKUP}" STREQUAL "${p}_LOOKUP-NOTFOUND" )
+- MESSAGE( STATUS "${p} found" )
+- ENDIF( "${${p}_LOOKUP}" STREQUAL "${p}_LOOKUP-NOTFOUND" )
++ STRING(FIND "${p}" "Qt" ISQT)
++ IF( ISQT GREATER -1 )
++ FIND_PACKAGE(Qt4 4.8 REQUIRED ${p})
++ ELSE( ISQT GREATER -1 )
++ FIND_LIBRARY( ${p}_LOOKUP "${p}" )
++ IF( "${${p}_LOOKUP}" STREQUAL "${p}_LOOKUP-NOTFOUND" )
++ MESSAGE( FATAL_ERROR "Linker-Library ${p} NOT FOUND" )
++ ELSE( "${${p}_LOOKUP}" STREQUAL "${p}_LOOKUP-NOTFOUND" )
++ MESSAGE( STATUS "${p} found" )
++ ENDIF( "${${p}_LOOKUP}" STREQUAL "${p}_LOOKUP-NOTFOUND" )
++ ENDIF( ISQT GREATER -1 )
+ ENDFOREACH()
+
+ ENDMACRO( FIND_LINKER_LIBS )
+@@ -616,6 +616,7 @@
+
+ QT4_AUTOMOC( ${${TARGETLIB}_SOURCES} )
+ QT4_WRAP_UI( ${TARGETLIB}_SOURCES "${${TARGETLIB}_WRAP_UI}" )
++ LINK_DIRECTORIES( ${QT_LIBRARY_DIR} )
+
+ ENDIF( QT_FOUND )
+
diff --git a/x11-libs/libyui/libyui-3.0.13.ebuild b/x11-libs/libyui/libyui-3.0.13.ebuild
new file mode 100644
index 000000000000..4667730c8f82
--- /dev/null
+++ b/x11-libs/libyui/libyui-3.0.13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="UI abstraction library"
+HOMEPAGE="https://github.com/libyui/libyui"
+SRC_URI="https://github.com/libyui/${PN}/archive/${PN}/master/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk ncurses qt4 static-libs"
+
+# Only Boost headers are needed
+DEPEND="dev-libs/boost"
+PDEPEND="
+ qt4? ( x11-libs/libyui-qt:${SLOT} )
+ ncurses? ( x11-libs/libyui-ncurses:${SLOT} )
+ gtk? ( x11-libs/libyui-gtk:${SLOT} )
+ "
+
+PATCHES=( "${FILESDIR}/${P}-fix-qt-libs-check.patch" )
+
+REQUIRED_USE="|| ( gtk ncurses qt4 )"
+
+S="${WORKDIR}/${PN}-${PN}-master-${PV}"
+
+src_prepare() {
+ cp buildtools/CMakeLists.common CMakeLists.txt || die
+
+ # TODO: set proper docs deps and USE flag for building them
+ sed -i -e '/SET_AUTODOCS/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
+ sed -i -e 's/src examples/src/' PROJECTINFO.cmake || die 'sed on PROJECTINFO.cmake failed'
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_WERROR=OFF
+ -DDOC_DIR="${EPREFIX}/usr/share/doc/${P}"
+ -DRESPECT_FLAGS=ON
+ $(cmake-utils_use_enable static-libs STATIC)
+ )
+ cmake-utils_src_configure
+}
diff --git a/x11-libs/libyui/metadata.xml b/x11-libs/libyui/metadata.xml
new file mode 100644
index 000000000000..b0ea2010f934
--- /dev/null
+++ b/x11-libs/libyui/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>miska@gentoo.org</email>
+ <name>Michal Hrušecký</name>
+ </maintainer>
+ <longdescription lang="en">
+YaST2 user interface engine that provides the abstraction from graphical user interfaces (Qt, Gtk) and text based user interfaces (ncurses). This can be used independently of YaST2 for generic (C++) applications.
+</longdescription>
+ <upstream>
+ <remote-id type="github">libyui/libyui</remote-id>
+ </upstream>
+</pkgmetadata>