summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/xcb-util-image
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/xcb-util-image')
-rw-r--r--x11-libs/xcb-util-image/Manifest2
-rw-r--r--x11-libs/xcb-util-image/files/xcb-util-image-0.3.9-return-type.patch46
-rw-r--r--x11-libs/xcb-util-image/metadata.xml5
-rw-r--r--x11-libs/xcb-util-image/xcb-util-image-0.3.9-r1.ebuild38
-rw-r--r--x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild37
-rw-r--r--x11-libs/xcb-util-image/xcb-util-image-0.4.0.ebuild33
6 files changed, 161 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-image/Manifest b/x11-libs/xcb-util-image/Manifest
new file mode 100644
index 000000000000..83e082f3b75b
--- /dev/null
+++ b/x11-libs/xcb-util-image/Manifest
@@ -0,0 +1,2 @@
+DIST xcb-util-image-0.3.9.tar.bz2 310947 SHA256 d35a3c0eaae171f5081ec127fb9cec174b716ce5d78196a87f2785376da021df SHA512 6cf7e191f3814528d977aa2acb2a106aaba0732c5d5f4041ac39039e18b9064f90f96da087300f4061d700e3521648e5540117794fdc41dad36ca5f973370394 WHIRLPOOL 6848c12e1f98a4989c8ae2f6765de99639aef178c28f5d782eca132e0ea7adf32aecbd1da0b2631213898a2315dec71beacb8a4dfc717d3701d6500e70092828
+DIST xcb-util-image-0.4.0.tar.bz2 327891 SHA256 2db96a37d78831d643538dd1b595d7d712e04bdccf8896a5e18ce0f398ea2ffc SHA512 9b7202c054e1160f9ca97a86be1210d9fb47f2119f89ca85f15f20909cca884bfe0cb88e3e71c75b65e1a0a72b980066ccac810e41a91db895c74dde77440d4f WHIRLPOOL aaf72ca6cc1599aa66d1638fca53df46b443d07baab4589577576c9c89d24c9e59bc6968e8e9faea3a9b4e69e009f0bf23596fcb462cc13f3e5153000158bb2c
diff --git a/x11-libs/xcb-util-image/files/xcb-util-image-0.3.9-return-type.patch b/x11-libs/xcb-util-image/files/xcb-util-image-0.3.9-return-type.patch
new file mode 100644
index 000000000000..d1ebc397a942
--- /dev/null
+++ b/x11-libs/xcb-util-image/files/xcb-util-image-0.3.9-return-type.patch
@@ -0,0 +1,46 @@
+From 3577db110e03985d4486cae6caf3ceb5696c45e9 Mon Sep 17 00:00:00 2001
+From: Jon TURNEY <jon.turney@dronecode.org.uk>
+Date: Thu, 20 Dec 2012 22:56:28 +0000
+Subject: Fix compilation when NDEBUG is defined
+
+XORG_DEFAULT_OPTIONS enables -Werror=return-type
+
+xcb_image_get_pixel() and xcb_image_create_native() assume assert(0) is
+noreturn, and don't return a value in that case. But assert(0) isn't noreturn
+if NDEBUG is defined.
+
+Fix this by returning a suitable value.
+
+(Also, on the MinGW target, assert(0) is non-standard and may return even in the
+!NDEBUG case, as the C runtime may ask the user if they want to abort or not...)
+
+/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c: In function 'xcb_image_get_pixel':
+/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c:754:1: error: control reaches end of non-void function [-Wreturn-type]
+/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c: In function 'xcb_image_create_native':
+/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c:190:1: error: control reaches end of non-void function [-Wreturn-type]
+
+Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk>
+Signed-off-by: Peter Harris <pharris@opentext.com>
+---
+diff --git a/image/xcb_image.c b/image/xcb_image.c
+index e426cbd..101aa4f 100644
+--- a/image/xcb_image.c
++++ b/image/xcb_image.c
+@@ -187,6 +187,7 @@ xcb_image_create_native (xcb_connection_t * c,
+ assert(0);
+ }
+ assert(0);
++ return NULL;
+ }
+
+
+@@ -751,6 +752,7 @@ xcb_image_get_pixel (xcb_image_t *image,
+ default:
+ assert(0);
+ }
++ return 0;
+ }
+
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/xcb-util-image/metadata.xml b/x11-libs/xcb-util-image/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-libs/xcb-util-image/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-libs/xcb-util-image/xcb-util-image-0.3.9-r1.ebuild b/x11-libs/xcb-util-image/xcb-util-image-0.3.9-r1.ebuild
new file mode 100644
index 000000000000..bad5828a2bfe
--- /dev/null
+++ b/x11-libs/xcb-util-image/xcb-util-image-0.3.9-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-image"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/xcb-util-${PV}[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-return-type.patch
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+
+ xorg-2_src_configure
+}
diff --git a/x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild b/x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild
new file mode 100644
index 000000000000..19f3ea94929b
--- /dev/null
+++ b/x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-image"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/xcb-util-${PV}
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.4 )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-return-type.patch
+)
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+
+ xorg-2_pkg_setup
+}
diff --git a/x11-libs/xcb-util-image/xcb-util-image-0.4.0.ebuild b/x11-libs/xcb-util-image/xcb-util-image-0.4.0.ebuild
new file mode 100644
index 000000000000..a6a0ecd5c6ff
--- /dev/null
+++ b/x11-libs/xcb-util-image/xcb-util-image-0.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-image"
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-${PV}:=[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+ xorg-2_src_configure
+}