summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-18 02:19:49 +0100
committerSam James <sam@gentoo.org>2022-09-18 02:26:04 +0100
commitbbb8661765e69f8f978d4894026cf0aff603f586 (patch)
tree7b46f950368faff46b12258589598bb6efe75f1b /x11-misc/xsetleds
parentmedia-sound/mpck: EAPI 8, fix implicit func. declarations (diff)
downloadgentoo-bbb8661765e69f8f978d4894026cf0aff603f586.tar.gz
gentoo-bbb8661765e69f8f978d4894026cf0aff603f586.tar.bz2
gentoo-bbb8661765e69f8f978d4894026cf0aff603f586.zip
x11-misc/xsetleds: update EAPI 6 -> 8, fix implicit func. declarations
Closes: https://bugs.gentoo.org/870571 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/xsetleds')
-rw-r--r--x11-misc/xsetleds/files/xsetleds-0.1.3-configure-implicit-function-decl.patch15
-rw-r--r--x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild16
2 files changed, 24 insertions, 7 deletions
diff --git a/x11-misc/xsetleds/files/xsetleds-0.1.3-configure-implicit-function-decl.patch b/x11-misc/xsetleds/files/xsetleds-0.1.3-configure-implicit-function-decl.patch
new file mode 100644
index 000000000000..4055e7a459a0
--- /dev/null
+++ b/x11-misc/xsetleds/files/xsetleds-0.1.3-configure-implicit-function-decl.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/870571
+
+Not sent upstream as it's a generated file and configure.in
+is written for autoconf 2.13.
+--- a/configure
++++ b/configure
+@@ -1057,7 +1057,7 @@ cat > conftest.$ac_ext << EOF
+ #line 1058 "configure"
+ #include "confdefs.h"
+
+-main(){return(0);}
++int main(){return(0);}
+ EOF
+ if { (eval echo configure:1063: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ ac_cv_prog_cc_works=yes
diff --git a/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild b/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild
index 1de8663792e8..5a8da903b1c3 100644
--- a/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild
+++ b/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit toolchain-funcs
-DESCRIPTION="small tool to report and change the keyboard LED states of an X display"
+DESCRIPTION="Small tool to report and change the keyboard LED states of an X display"
HOMEPAGE="https://github.com/bmeurer/xsetleds"
SRC_URI="
ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/src/${P}.tar.gz
@@ -23,14 +24,15 @@ DEPEND="
${RDEPEND}
x11-base/xorg-proto
"
+
PATCHES=(
"${FILESDIR}"/${P}-assignment.patch
"${FILESDIR}"/${P}-isalpha.patch
+ "${FILESDIR}"/${P}-configure-implicit-function-decl.patch
)
-src_prepare() {
- default
+src_configure() {
tc-export CC
-}
-DOCS=( AUTHORS ChangeLog README TODO )
+ default
+}