summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-05-28 23:56:26 +0100
committerMarek Szuba <marecki@gentoo.org>2022-05-29 00:55:07 +0100
commit0d1ba3f496ba4a7ed4837e4a585ada5f230aa739 (patch)
tree930b67de501294916a59a0c4fd00c2003b750df8 /x11-misc
parentx11-misc/i3lock: add github upstream metadata (diff)
downloadgentoo-0d1ba3f496ba4a7ed4837e4a585ada5f230aa739.tar.gz
gentoo-0d1ba3f496ba4a7ed4837e4a585ada5f230aa739.tar.bz2
gentoo-0d1ba3f496ba4a7ed4837e4a585ada5f230aa739.zip
x11-misc/i3lock: add 2.14
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/i3lock/Manifest1
-rw-r--r--x11-misc/i3lock/i3lock-2.14.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/i3lock/Manifest b/x11-misc/i3lock/Manifest
index 7d62c540ae72..d9ea93d622f9 100644
--- a/x11-misc/i3lock/Manifest
+++ b/x11-misc/i3lock/Manifest
@@ -1 +1,2 @@
DIST i3lock-2.13.tar.bz2 149332 BLAKE2B 4b285fb3a27463f0d538d291134942a19933394c4c2d0acf27dfe5624a854cef0f29c5fc2e4ce4398c85ac0e6b774521c7daa65abedc0d38b0fd4897b2e6db88 SHA512 3a9bed3d14a2d59e641b3603448bb46d769104995b1c0239eca87d582e80e64dd8905b8e455bd5b0e635d4b37d7a87208d8de37253e9af799c65f4f8d396789d
+DIST i3lock-2.14.tar.xz 28648 BLAKE2B ef315c4d1175a692b8ea2ac1a6a9cefdaa642fc28cfcc28cbf0c637f9d0cf0ea47738447cf0d90c3c2f869819c178a416aabc44dbfe93ab938e48da2a0143d0a SHA512 85f755333739e61a8ac90447410c48cf54345740bb6c6977efa88500e2b66dfd7fe3338e4fe38f817773219e5994ef6375010fdb3cf711e2ad42045874e39e20
diff --git a/x11-misc/i3lock/i3lock-2.14.ebuild b/x11-misc/i3lock/i3lock-2.14.ebuild
new file mode 100644
index 000000000000..29d754d62271
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="https://i3wm.org/i3lock/"
+SRC_URI="https://i3wm.org/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-libs/libev
+ sys-libs/pam
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-xrm"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:login:system-auth:g' pam/${PN} || die
+}