summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-01-13 17:46:42 +0100
committerJeroen Roovers <jer@gentoo.org>2017-01-13 17:46:42 +0100
commit18774a79ff0d7322630b0fee5da7e583c511753f (patch)
treee92c6d73e5c9b6a0d7561cc887ec63d3893cbabc /x11-misc
parentdev-python/unidecode: Version bump. (diff)
downloadgentoo-18774a79ff0d7322630b0fee5da7e583c511753f.tar.gz
gentoo-18774a79ff0d7322630b0fee5da7e583c511753f.tar.bz2
gentoo-18774a79ff0d7322630b0fee5da7e583c511753f.zip
x11-misc/rofi: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.3.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index 752adfb854b9..fdb4d5ae19fe 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,2 +1,3 @@
DIST rofi-1.2.0.tar.xz 188760 SHA256 0c2b504bdd17e41ee61828671cd85698c38cff3128e1ae44841466d86f07bd77 SHA512 6afbec388fb3d0cb83011f2790f5f5a7e2d63b0436d183722b59c39852b5bc2896a46a32445decc6c36bd25c0e33a3658e31b1a307d72950e87f4838102b9838 WHIRLPOOL da483f36e92fc978f335547ec540227be3561e309bff573ab26c36829e18737e7152453eaef9f9848c1737d72980ad7c09b2411c4846f1e6dd97b378939c2480
DIST rofi-1.3.0.tar.xz 210936 SHA256 164b094d03575cdbf4c0740e6e29fe54e33f62d180f11357d12a3f3f5254c5a8 SHA512 65d31f3df09d1826a816d652b372e21f278b324195d7df2304aa7d5bb6b964ac2ec6a09df9b3deaa93ee83d76a699188460c0e96f02822251567526f24e46587 WHIRLPOOL a74eee3d6549736c7836890115d4f753d92dc67c12a6354249b0b8ef724f3bce2d373fe4f7d58d4138c653e21e34d5854c6a3449cdf739dbfe282b6a5924abee
+DIST rofi-1.3.1.tar.xz 211732 SHA256 b52cf1170f5c7c38f6399ee44f23ebbd87ac349d6a34f32f5d169966765c87e8 SHA512 a96c53ad268883277c4ff0ee3267ff7fab4d4a93a982019ce19ea82771b65c32d56216d777494853bffd18481400af72ed777f88cce4b26d7d1b8980a997f6c6 WHIRLPOOL 47ca4050853888fda4ae9dc203c3d4a47284780d8d1506b12f4bb14cb947a8a7e96b3674203b518ada6b9bbd0e5718d49a42f89a2ecbdf26b3fdacce9d9fee6f
diff --git a/x11-misc/rofi/rofi-1.3.1.ebuild b/x11-misc/rofi/rofi-1.3.1.ebuild
new file mode 100644
index 000000000000..3bffd04c76be
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://davedavenport.github.io/rofi/"
+SRC_URI="https://github.com/DaveDavenport/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+ x11-proto/xproto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable windowmode)
+}
+
+src_test() {
+ emake test
+}