summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-31 23:29:58 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-10-31 23:29:58 +0100
commit29ca21254bac80a023a11a51e61d029853fc4587 (patch)
tree73aef7b8adb1f62f200fdc26c40b866d0183ecb0 /x11-misc
parentapp-emulation/docker: 1.12.3 version bump (diff)
downloadgentoo-29ca21254bac80a023a11a51e61d029853fc4587.tar.gz
gentoo-29ca21254bac80a023a11a51e61d029853fc4587.tar.bz2
gentoo-29ca21254bac80a023a11a51e61d029853fc4587.zip
x11-misc/flow-pomodoro: Version bump to 1.1.2
Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/flow-pomodoro/Manifest1
-rw-r--r--x11-misc/flow-pomodoro/files/flow-pomodoro-1.1.2-compiler.patch30
-rw-r--r--x11-misc/flow-pomodoro/flow-pomodoro-1.1.2.ebuild25
3 files changed, 56 insertions, 0 deletions
diff --git a/x11-misc/flow-pomodoro/Manifest b/x11-misc/flow-pomodoro/Manifest
index 74abdbce3ce8..11b880236550 100644
--- a/x11-misc/flow-pomodoro/Manifest
+++ b/x11-misc/flow-pomodoro/Manifest
@@ -1 +1,2 @@
DIST flow-pomodoro-1.1.1.tar.gz 684633 SHA256 311d22dcfe57dd7c236a2632368abdc667f42aaf7f1d713393d9dbbc12c3a855 SHA512 9a97d553b7a7ec5c32c0b6002e9f194fc297ef3fc18cb41d3ae7ca602d42d1313b1602e094f669f558ab15b7519c880dd12867724d5b2324f6e2d34ee409496d WHIRLPOOL f3183d0d3542f7fe28f97ed391dcc5e308cb783e27ca6b204623f14cefa722f2f28eda2d40203dbd0ba4c28c490c9bfc7861ba331c40dcd69152e126ec91828a
+DIST flow-pomodoro-1.1.2.tar.gz 686290 SHA256 96786f4fcb90efadbb129bf40f14cf143f2ea9137101d2c24bdcab00d2357e11 SHA512 73a37e5c63a14777b21bef61cd81003548119670b74ae9de2eb5fff4cd27f159429c9aded06638bd77e52967a0a2cfb69f4055709ed136b5ef39a4d3ccd90ab7 WHIRLPOOL f51d74579d26565e00cc57b49070f2a1e507299fbada924197963606ed5ce598168a0964ddfb755184227244eff2f97ae6b1d2780c376685b0b5b1faa7192f8b
diff --git a/x11-misc/flow-pomodoro/files/flow-pomodoro-1.1.2-compiler.patch b/x11-misc/flow-pomodoro/files/flow-pomodoro-1.1.2-compiler.patch
new file mode 100644
index 000000000000..e15e32faa9a1
--- /dev/null
+++ b/x11-misc/flow-pomodoro/files/flow-pomodoro-1.1.2-compiler.patch
@@ -0,0 +1,30 @@
+From 42022f4989958d87e27d2dd5029d5cf8d0a42efa Mon Sep 17 00:00:00 2001
+From: Sergio Martins <iamsergio@gmail.com>
+Date: Sun, 30 Oct 2016 22:50:47 +0000
+Subject: [PATCH] Fix build with older gcc compilers
+
+---
+ CMakeLists.txt | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 010333f..06a4a77 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -14,6 +14,16 @@ include_directories(${Qt5Gui_INCLUDES})
+
+ set(CMAKE_CXX_FLAGS "${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
+
++include(CheckCXXCompilerFlag)
++CHECK_CXX_COMPILER_FLAG("-std=c++11" COMPILER_SUPPORTS_CXX11)
++CHECK_CXX_COMPILER_FLAG("-std=c++0x" COMPILER_SUPPORTS_CXX0X)
++if(COMPILER_SUPPORTS_CXX11)
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
++elseif(COMPILER_SUPPORTS_CXX0X)
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++else()
++ message(STATUS "The compiler ${CMAKE_CXX_COMPILER} has no C++11 support. Please use a different C++ compiler.")
++endif()
+
+ add_subdirectory(src)
+ add_subdirectory(plugins)
diff --git a/x11-misc/flow-pomodoro/flow-pomodoro-1.1.2.ebuild b/x11-misc/flow-pomodoro/flow-pomodoro-1.1.2.ebuild
new file mode 100644
index 000000000000..b03559feb484
--- /dev/null
+++ b/x11-misc/flow-pomodoro/flow-pomodoro-1.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A pomodoro app that blocks distractions while you work"
+HOMEPAGE="https://github.com/iamsergio/flow-pomodoro"
+SRC_URI="https://github.com/iamsergio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"