summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-06-25 21:13:09 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-06-25 21:13:19 +0200
commit439544e4ff75d22ce06faa8f045f1a91595ea73a (patch)
tree37d02226d115a213b8bc77120030bf876930780c /x11-misc
parentdev-ruby/fiber-annotation: new package, add 0.2.0 (diff)
downloadgentoo-439544e4ff75d22ce06faa8f045f1a91595ea73a.tar.gz
gentoo-439544e4ff75d22ce06faa8f045f1a91595ea73a.tar.bz2
gentoo-439544e4ff75d22ce06faa8f045f1a91595ea73a.zip
x11-misc/autorandr: add 1.14
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/autorandr/Manifest1
-rw-r--r--x11-misc/autorandr/autorandr-1.14.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/x11-misc/autorandr/Manifest b/x11-misc/autorandr/Manifest
index a7ff290a6551..6553aa5e1ee3 100644
--- a/x11-misc/autorandr/Manifest
+++ b/x11-misc/autorandr/Manifest
@@ -1,2 +1,3 @@
DIST autorandr-1.12.1.tar.gz 45550 BLAKE2B 5b434325d13c00c3fa70b5d09edb540cdcf3bb921307c60f2c616231e7a87ea85f60e39500ed8116f28619139f71ecc4a8fa153ffadc6b8d74df570736a0d815 SHA512 a7e095eb96e7e0d3a5b3b2122d68a3d3a5121d8be7a86ddd9f837ad42b7a53ed5ee45151f23861c5b900e214a4dfc0c575f45fe70c8c5587562a4035458137a0
DIST autorandr-1.13.3.tar.gz 47630 BLAKE2B fb53316af4d3fa399f278be874e95d06cbd188bebf1e22793ca30ad4f9a8817674390c7d02d501f4a35a0a6f23b16202e97f2a6559727e67e908d21121de8a56 SHA512 6c3f99da52a029a8f1717020ebafbd7afb58d97651776a6620f47e299584704ab65c37be5e9497cca3c53d6268ebde11481f32967ec289adf606a73e587e874f
+DIST autorandr-1.14.tar.gz 49234 BLAKE2B 3ff149d30b023bc54d83c4be1f81f67204d20d3e6a7a43e15009c1c4f1180fa920789ce84ae56f13946a9cec1f72bc7adb27be3c58ca8532235d0457b1f5aa92 SHA512 dc1ee4c28b06dde4a721fe564734e7a79c1c843986f7c84307ea60f19c2237ba53d1bcd2202e377363e7e0a5bf5dea95bea4490b3fa5ec5fa6738114646a502d
diff --git a/x11-misc/autorandr/autorandr-1.14.ebuild b/x11-misc/autorandr/autorandr-1.14.ebuild
new file mode 100644
index 000000000000..5a4cdc0e7c9f
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-1.14.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit bash-completion-r1 distutils-r1 systemd udev
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
+else
+ SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Automatically select a display configuration based on connected devices"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="launcher systemd udev"
+
+RDEPEND="
+ x11-apps/xrandr
+ launcher? ( x11-libs/libxcb )
+ udev? ( virtual/udev )
+"
+DEPEND="${RDEPEND}"
+# desktop-file-util: uses desktop-file-edit in Makefile
+BDEPEND="
+ dev-util/desktop-file-utils
+ virtual/pkgconfig
+"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use launcher; then
+ emake contrib/autorandr_launcher/autorandr-launcher
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman autorandr.1
+
+ local targets=(
+ autostart_config
+ bash_completion
+ $(usev launcher)
+ $(usev systemd)
+ $(usev udev)
+ )
+
+ emake DESTDIR="${D}" \
+ BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
+ SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ $(printf "install_%s " "${targets[@]}")
+}
+
+pkg_postinst() {
+ if use udev; then
+ udev_reload
+ fi
+}
+
+pkg_postrm() {
+ if use udev; then
+ udev_reload
+ fi
+}