summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmpasman
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmpasman')
-rw-r--r--x11-plugins/wmpasman/Manifest2
-rw-r--r--x11-plugins/wmpasman/metadata.xml15
-rw-r--r--x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild32
-rw-r--r--x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild24
4 files changed, 73 insertions, 0 deletions
diff --git a/x11-plugins/wmpasman/Manifest b/x11-plugins/wmpasman/Manifest
new file mode 100644
index 000000000000..727e11afecd9
--- /dev/null
+++ b/x11-plugins/wmpasman/Manifest
@@ -0,0 +1,2 @@
+DIST wmpasman-0.8.4.1.tar.gz 226277 SHA256 79be58cad5d4e6c5e15969e3d5a4fa1dfe59687b59e81c5802426c900aecd733 SHA512 59c811ad998a522c255c52bed656e2b5eb9cfbe01913d8fc0d686c82df22543bbe776104f2c141152bd0925990cf590216452e4e3cfe78c85e4ee4d67e69e4c8 WHIRLPOOL 51f51f2c92b9067cab2bedd814a0067daa9af72411a46a6f5b3980253f22a241c74ada6cef31e8ed82b05a2c515974024a5545dfd96e6cfb14be1c7dc9a75254
+DIST wmpasman-0.8.5.3.tar.gz 198779 SHA256 7db784891a73d80e5c386911142fd66b3bee3bd5dcdc35da3355b87aff5ce4b6 SHA512 d47bae993b1ea47ef2cf4cce0dc8d8f1e8e055650dbfc7854612176a0933a0a5079ad29bc85ba8e0370843e9be189d7e4d0b349590981d3eac4c3f01fe69ec87 WHIRLPOOL 8e9fce9faba17d03a2454c0fc8904206d6a2ec566f86e1c8538194aa313be4411c94e8d0d0d2bc26dacc2539305f21a5fbfbb87e8566c39d6f3f6451375cecb7
diff --git a/x11-plugins/wmpasman/metadata.xml b/x11-plugins/wmpasman/metadata.xml
new file mode 100644
index 000000000000..09ecaf0de8db
--- /dev/null
+++ b/x11-plugins/wmpasman/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <longdescription>
+wmpasman stores passwords and makes them available
+for pasting (both via the middle-click primary
+selection and the clipboard selection) at the
+click of a button. It also contains a digital
+clock. Access is controlled by a passphrase.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">wmpasman</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild b/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild
new file mode 100644
index 000000000000..f25e7bda7ba8
--- /dev/null
+++ b/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Password storage/retrieval in a dockapp"
+HOMEPAGE="http://sourceforge.net/projects/wmpasman/"
+SRC_URI="mirror://sourceforge/wmpasman/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4.1:2
+ >=app-crypt/mhash-0.9.1
+ >=app-crypt/mcrypt-2.6.4"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ virtual/pkgconfig
+ >=x11-libs/libXpm-3.5.5"
+
+src_prepare() {
+ # Solves compile error about undefined exit - Bug 140857
+ sed -i -e '/#include <stdio.h>/ { p ; s/stdio/stdlib/ }' wmgeneral/wmgeneral-gtk.c || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc BUGS ChangeLog README TODO WARNINGS
+}
diff --git a/x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild b/x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild
new file mode 100644
index 000000000000..be2211c947cd
--- /dev/null
+++ b/x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Password storage/retrieval in a dockapp"
+HOMEPAGE="http://sourceforge.net/projects/wmpasman/"
+SRC_URI="mirror://sourceforge/wmpasman/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4.1:2
+ >=app-crypt/mhash-0.9.1
+ >=app-crypt/mcrypt-2.6.4"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ virtual/pkgconfig
+ >=x11-libs/libXpm-3.5.5"
+
+DOCS="BUGS ChangeLog README TODO WARNINGS"